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QuantAsylum QA403 Tutorial 
Version 3.0 - 1/18/2025 

Bob Cordell 
 

This version includes updates to the previous manual and automated tests, and 

more information on measurement procedures and analyzer performance. 

 

Introduction 
This tutorial is a step-by-step run-through for measuring a power amplifier. The 

amplifier being tested is the BC-1 power amplifier conservatively rated at 140 Watts for 

one channel into 8 Ω with power rails that are ±65 V at idle and ±59 V at 140 Watts. It is 

rated at 230 W into 4 Ω with the power supply sagging to ±54 V. Clipping points are 175 

W and 280 W, respectively. The BC-1 is capable of more power with higher supply rails or 

stiffer supply rails. The BC-1 is a class-AB bipolar design that employs two output 

transistor pairs in a Locanthi T triple emitter follower configuration. It is a refined version 

of the power amplifier described in Chapter 4 of "Designing Audio Power Amplifiers" by 

this author [1]. It is also described on the cordellaudio.com website [2]. Printed wiring 

boards and detailed BOMs are available on eBay [3]. If you don't have a power amplifier 

to test, virtually all of these QA40x test procedures can be run on a small-signal amplifier, 

such as an op amp gain stage. 
 

Most of the tests below are written in a stand-alone format for all of the setup 

steps required. A great many of those tests have the same setup steps in common. In 

practice, a test has a group of setup steps to be done first using the control panel and 

the "add measurements" selections. To a very large extent, these setup steps are 

common to all of the tests. Most of the setup can be entered from a file that has been 

stored via the File > Save Settings command from a previous test that has been run.  For 

a new test, like one of the ones below, most of the setup steps can be accomplished via 

the File > Load Settings command using a previously stored command. If needed, those 

settings can be tweaked a bit to better suit the test to be run. Those setup files are 

provided on this site. 
 

If making a setting is not mentioned in the setup for one of the exercises below, 

it means that that setting is simply left at its default setting. For example, the XLOG 

frequency range default is 20 - 20 kHz. After entering the File > New Settings command 

at the beginning of a measurement, all settings will be at their default values. 
 

The QA40X software creates a QuantAsylum > QA40x folder on your PC. That 

folder contains several folders, like UserWeighting and CalibrationData. For convenient 

storage of measurement setup files, create a folder called Measurement Settings in the 

QA40X folder.   Similarly, create a folder named something like Figures in the QA40X 

folder for storage of screen shots, Visualizer images, etc. 
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Routine Settings 
Many of the settings are similar for the different measurements, and many are 

not really critical. When just one channel of an amplifier is being measured, the right 

channel is usually turned off. The full scale input (FSI) is usually set just so that the 

analyzer is not overloaded, and has some operating margin. This is not critical, but it is 

helpful in cases where noise is being measured to make sure that the analyzer noise 

(which is very low) is not influencing the measurement. An input signal that exceeds the 

FSI value will likely be clipped. Signals to be measured should be below the FSI value by 

some margin. 
 

The maximum value of FSI=42 dBV does NOT mean that the maximum input to 

the analyzer can be +42 dBV. The maximum input to the analyzer is 32 dBV, 

corresponding to 40 Vrms and 200 Watts into 8 Ω, and must not be exceeded. 
 

In going between FSI=18 dBV and 24 dBV, you will hear a relay click. This is a 24-

dB signal-level hardware scaling attenuator that is being activated or not. It will change 

the noise floor of the QA40X by about 20 dB. If you can stay on the 18 dBV (or less) side 

of that divide, there will be a much lower analyzer noise floor, and analyzer noise is far 

less likely to influence what you see. Analyzer distortion is also lower for FSI < 24 dBV. 
 

The FFT and data acquisition settings include sample rate, FFT size and averaging. 

These are relatively uncritical for most tests, and often a sample rate of 48 kHz and FFT 

size of 32k with no averaging is adequate. On the other hand, using a high sample rate, 

such as 192 kHz, makes the measurement time shorter for a given FFT size, and there is 

little downside. It allows using a large FFT size to make some measurements more 

precise while mitigating the associated increase in measurement time.  
 

The use of a higher sample rate is necessary if the measurement is to extend to 

higher frequencies, such as the rough maximum of 80 kHz with a sample rate of 192 kHz. 

Measurements down to low frequencies below 20 Hz, such as some frequency response 

measurements, will often require a larger FFT, sometimes as large as 256k or even 512k. 

To no surprise, measurements at such low frequencies can take a long time. A THD 

measurement at 20 Hz requires a 128-k FFT. A smaller FFT will result in excess distortion 

being reported and some possible signal level attenuation. When in doubt, in many 

cases a sample rate of 96 kHz and FFT size of 64k usually is satisfactory. 
 

Averaging helps with measurements of noise and visibility of harmonics that 

might otherwise be buried in the noise. However, it increases the initial measurement run 

time (the averaging is a moving average). In the measurements below, we err on the side 

of higher sample rates and larger FFT size as long as the measurement time is 

convenient. Averaging should not be used when doing the automated measurements. If 

you have averaging enabled, the system will reset averaging between each run of an 

automated test. 
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There is the option to restore measurement state after an automated test is 

performed. This is enabled by default (see Edit->Settings “Restore State After Automated 

Test Run”). What this means is that if you are making manual measurements at 1 kHz, 

and then you run an automated test that finishes at 20 kHz, the system will revert to the 

settings before the Automated Test was run IF you have opted to Restore State and you 

will again be working at 1 kHz. If you have not opted to restore state, then the after the 

Automated Test run, the settings will be at the final Automated Test state.  
 

Saving Settings 
The measurements below require that certain commands and features of the 

tests be set up before the test is run. These include things like sample rate, FFT size, 

measurement results to be displayed, etc. These setups can be saved and recalled for 

later running of the same type of tests.  
 

In preparation for subsequent running of the tests to follow, save the settings 

currently in place. Go to File > Save Settings. In the dialog that comes up, name the file 

something like "THD". Navigate to your QuantAsylum > QA40X > Measurement Settings 

folder where you will store the settings and click save. The settings will be saved as 

THD.settings. It will be available for use as an existing setup as you left it here and can be 

loaded by going to File > Load Settings > Measurement Settings the next time you run 

this type of test. Permanent settings files can be loaded at any time. Loading them will 

save a lot of setup effort when such measurements are done again. The measurements 

to be done below, like frequency response, will result in different settings that can be 

stored in the same QA40X folder with a different file name. 

 

Loading Settings 
There are normally several setup steps to do a measurement, such as sample rate, 

FFT size, measurement types needed, etc. These can be seen in the measurement 

procedures below. For virtually all of these measurements, the group of setup steps will 

have been saved into a setup file after the first time the measurements are made. This 

makes doing measurements later quite fast, allowing one to bypass most of the setup 

steps. The setup files created in these exercises include the following:  
 

 Gain.settings 

 Frequency Response.settings 

 Noise.settings 

 Noise Density.settings 

 SNR.settings 

 THD.settings 

 THD vs Frequency.settings 

 Burst Power.settings 

 CCIF 19_20.settings 

 SMPTE IM.settings 

 Multitone.settings 
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 Crosstalk.settings 

 Output Impedance.settings 

 Default.settings 

 

Saving the Screen Image 
Go to File > Save Bitmap as ... There you will have the choice to save the screen 

image as a JPEG, PNG or Bitmap to your QA40X folder. This makes it easy to embed 

graphic QA40X measurement results into documents, PowerPoint  presentations, etc. If 

you prefer a dark-on-light presentation of the screen, go to Edit > Settings > Display 

Options and select "Dark-on-Light". This procedure will save the screen image, including 

the dashboard presentations of setup and numerical results. If you prefer to capture just 

the plot, right click on the plot instead and hit "Save Image as ...". 

 

Markers and Cursors 
A marker can be placed on an FFT line by clicking at the top of the line. The 

frequency and dBV amplitude of the line will be displayed in pink in the upper right of 

the display. If a marker is first placed on the line of maximum amplitude to make it a 

reference (often the fundamental frequency), a second value for other markers will 

display the relative amplitude to the marked reference in dBc.  Markers will be numbered 

and ordered in accordance with their amplitude. Adding a new marker may change the 

assigned number and order of the previous markers.  
 

All markers can be deleted by right-clicking in the marker display area and 

selecting Delete All Markers. In a dense FFT display, or where some lines are of small 

amplitude, it may be easier to place markers on some lines by zooming in on those areas 

of the FFT display by clicking and dragging in the display. The display can be un-zoomed 

by clicking in the small square that is displayed in the lower right corner of the display. 
 

Two cursors, C1 and C2, are available in the CURSORS section of the control area. 

They can be moved left or right by clicking on their number designation and dragging 

them left or right to a location whose frequency and amplitude will be read out in white 

characters in the cursor data area at the bottom left of the screen. Pushing the CENTER 

button for a cursor moves it to the center of the display. Pushing the PEAK button moves 

it to the center of the nearest FFT line. Note that it may be moved to a peak of very small 

amplitude that is next to a larger desired peak. Markers can only be added when just the 

left channel is active.  
 

Markers can be moved in a zoomed-in screen, and this can be helpful in marking 

a desired line or marking its peak in a crowded FFT. However, if a marker is activated 

while zoomed in, it appears off-screen in the center of the un-zoomed screen. In this 

case, push its CENTER button to move it to the center of the zoomed screen area so that 

it can then be dragged to the desired location. The screen can subsequently be un-

zoomed by clicking on the lower-right square to see the big picture. 
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Minimizing Hum and Noise in Measurements 
Hum and noise from the testing arrangement can be problematic in sensitive 

measurements like those for noise. These unwanted corrupters of signals and the 

measurement can come from the environment, not the devices being measured. Ground 

loops, dirty AC lines, noise from associated computers, USB connections and even 

radiated emissions can be typical culprits. A sensitive FFT measurement on the QA40X 

can reveal 60-Hz hum and many of its harmonics due to pickup from the environment, 

and not necessarily due to the power supply in the amplifier under test. Devices like 

switching power supplies and converters, including those in CFL and LED lights, can 

create a spray of harmonics in the upper audio band that will be visible in the FFT 

display. 
 

Best noise measurement results are obtained when CFL and LED lights are turned 

off. For best results on all noise measurements, especially those including both input and 

output of the QA403 connected to the output and input of the amplifier, use a laptop 

running on its battery as the computer for the QA40X. Results with a desktop computer 

can sometimes be improved by passing the computer's USB through a powered USB 

hub. This will also largely guarantee that the QA40X has adequate voltage from its USB 

connection. The computer and the amplifier under test should be connected to the same 

power outlet.  
 

Balanced/differential connections to the QA40X using shielded twisted pair 

cables (e.g. microphone cables) can be used to improve matters even if the amplifier has 

a single-ended input. This helps to avoid ground loops that involve the input and output 

cables to and from the amplifier and QA40X. In one approach, connect the negative 

signal of the balanced cable to the shield at the input to the amplifier under test. 

Connect the shield to one of the BNC output grounds at the QA40X. Connect the shield 

to the negative signal lead where the other cable connects to the ground side of the 

amplifier output. Connect the shield of that cable to one of the BNC input grounds of the 

QA40X input. This interconnect arrangement is not Gospel, and some experimentation 

may be required. The QA40X FFT is brutal in unmasking hum and noise that gets into the 

test setup from the environment.  
 

Another quasi-balanced/differential approach is also recommended, especially 

for damping factor measurements, but also effective in reducing pickup of hum and line 

harmonics. Connect the single-ended output of the QA40X directly to the single-ended 

input of the amplifier under test with a single ended shielded cable. Connect the 

conventional single-ended output of the amplifier to the balanced differential inputs of 

the QA40X through a shielded twisted pair interconnect, like a microphone cable. The 

twisted pair should be connected with its cold and hot wires with stripped ends to the 

amplifier's output jacks, screwed down and through the inner holes of the usual banana 

speaker connectors, or equivalent. The load resistor is then connected with banana plugs 

or spades to the output terminals after the twisted pair measurement cable. This is 

somewhat like a Kelvin connection, minimizing effects of load current on what the 
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balanced measurement cable sees. Do not connect the shield at the amplifier end. 

Connect the shield to one of the BNC connector grounds at the QA40X balanced input. 

An approach like this is especially helpful in obtaining accurate measurements of 

damping factor, where very low amplifier output resistances are involved. Depending on 

the amplifier and environment, some experimentation with interconnections and 

grounding between the QA40X and amplifier may be helpful. 
 

The interconnect from the QA40X output to the input of the amplifier should be 

short and direct. It should not pass anywhere near the amplifier's output transistors. 

Remember, with a typical power amplifier with a gain of about 20, this interconnect is 20 

times more sensitive to corruption than the interconnect from the amplifier output to the 

QA40X input. 

 

Measuring High-Power Amplifiers 
In light of the analyzer maximum input signal level of +32 dBV, corresponding to 

40 Vrms or 200 W into an 8-Ω load, external attenuation of the amplifier signal must be 

used for high-power amplifiers. In fact, the analyzer should be operated with some 

margin against the 32-dBV limit to ensure good performance. Note that the full-scale 

input setting of +42 dBV does NOT mean that a +42 dBV signal can be applied to the 

analyzer. It merely means that an internal 42-dB attenuator precedes the ADC. 
 

The external attenuator may take many forms, with one or more amounts of 

attenuation and physical implementation, such as a load power resistor equipped with 

one or more taps. It may also take the form of a simple resistive divider as long as the 

source resistance it shows to the input of the analyzer is fairly low so that there is no 

extra loss or high-frequency response degradation due to resistive and capacitive 

loading.  
 

Because the QA40X has selectable input attenuation in 6-dB steps from 0 dB to 

42 dB, few external attenuation taps are usually required. For best noise performance, 

different measurements may require different amounts of attenuation, with noise 

measurements generally requiring that there be little or no attenuation. 
 

With external attenuation there comes the need to inform the QA40X of how 

much attenuation is being applied so that the analyzer can take that into account so that 

voltage levels are measured and reported accurately. If external attenuation is in play, 

click on the dBV button and enter the amount of external attenuation into the external 

input gain box as a negative dB number, such as -20 dB. 
 

One approach to external attenuation is to use a 24-dB attenuator, which 

accurately shifts the 24- to 42-dB FSI settings of the QA40X down into the 0- to 18-dB 

FSI range where QA40X noise and distortion performance is superior. 24 dB corresponds 

to a loss ratio of 15.85. If a 1-kΩ shunt resistor is used in the divider, then the series 

resistor should be 14.85 kΩ. The fairly low source resistance of the divider will create 

thermal noise of only about 4 nV/√Hz. An amplifier delivering 400 W into an 8-Ω will 
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produce 56.57 Vrms. This will result in 3.57 mA flowing in the total 15.85-kΩ resistance of 

the divider, for power dissipation of 202 mW. Note that a total cable-plus-QA40X 

capacitive load of 160 pF on a source resistance of about 1 kΩ will limit 3-dB bandwidth 

to 1 MHz. For minimal resistor heating and low-frequency thermal distortion, resistor 

power ratings should be at least 10 times the working power dissipation. For example, 

use a 1-Watt 1-kΩ shunt resistor and a 2-Watt resistor trimmed to 14.85-kΩ for the 

series resistor. 

 

Shorting Blocks 

Many measurements below specify the use of shorting “plugs” or “blocks” on the 

unused inputs (never use them on the analyzer outputs!). These can be 0/50/75 ohms 

and are commonly available from Amazon if you search for “BNC shorting blocks”. A 

good starting point before a measurement session is to install 4 shorting plugs on the 

QA403 inputs, select File->New Settings, set the Full Scale Input (FSI) to 0 dBV, sample 

rate to 48 kHz, increase FFT size to 64k or so, add RMS dBV and RMS Volts 

measurements, and verify you are seeing -117 dBV or so on both the left and right 

channels. You should see no power line components displayed. Change the sample rates 

to 96 kHz and 192 kHz and confirm the noise measurements aren’t changing. 
 

The shorting blocks will wear out in time. If you see noise or power line sensitivity 

related to slight lateral forces applied to the block, then throw the block away. 

Remember, you are trying to measure hundreds of nanovolts in some cases, and so a 

shorting block that isn’t reliable can consume hours of debugging effort.  
 

If you are seeing power line components in this baseline configuration, look for 

nearby environmental factors, especially including equipment with large transformers. 

 

Loop Back Performance 

Here the QA403 used in these measurements of the BC-1 power amplifier is 

configured in a single-ended loop back configuration and the performance metrics are 

shown for reference. The 1-kHz loop back is done at 0 dBV with FSI = 18 dBV. Sample 

rate is 192 kHz, FFT is 128k with 10 averages and a Hann window. These settings, 

including the large number of averages, will demonstrate the achievable performance of 

the analyzer in a typical situation.  
 

Measurement tiles activated include Gain, pk dBV, Pk Vrms, THD dB, THD+N dB, 

SNR dB and RMS volts. The RMS noise voltages recorded are with Gen 1 off. The FFT 

noise floor is the approximate dBV value where the center of the noise portion of the FFT 

lies. The FFT noise floor is important in seeing and determining the amplitudes of the 

smaller-amplitude harmonics. These performance numbers will differ from unit to unit, 

and, in fact, between left and right channels, as can be seen below. If one does loop back 

testing at higher frequencies like 5 kHz and above, XLOG and RMS or THD should be set 

to top measurement frequencies of 85 kHz to capture upper-frequency harmonic 

products and noise. A screen shot of the 1-kHz loop back results is shown in Figure 1. 
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    1 kHz  1 kHz 

 Measurement   Left  Right 

 THD, dB   -120  -114 

 THD+N, dB   -108  -106 

 FFT noise floor, dBV  -145  -142 

 2nd harmonic, dBV  -135  -130 

 3rd harmonic   -124  -120 

 4th harmonic   noise  noise 

 5th harmonic   -124  -120 

 SNR, dB    109   107 

 RMS noise, µV     3.3    3.3 

 

 
 

Figure 1: Screen Shot of the QA403 Loopback Measurement 
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The FFT noise floor depends on FFT size. If you have enabled RtHz (in dBV 

Context Menu) then the noise floor will show the same regardless of FFT size. However, 

peaks may then be rendered wrong. 

 

The Full Scale Input (FSI) is set to +18 dBV for the above loopback measurements 

of a 0 dBV signal. There is a tradeoff between analyzer SNR and analyzer distortion floor. 

The value of FSI is the amplitude at which the ADC in the QA403 is being driven to its 

maximum rated input level. As such, its distortion will be a bit higher than at other 

settings, like at +18 dBV where headroom against maximum input level is 18 dB. 

Conversely, the analyzer SNR is best when FSI with a 0 dB signal is set to 0 dBV, since 

there is less input attenuation ahead of the ADC. FSI settings at and above 24 dBV incur 

a significant amount of attenuation that ends up eating into the SNR and distortion 

floor. 

 

Analyzer Noise vs FSI Setting 
The FSI setting places different amounts of attenuation or gain in the signal path 

in front of the ADC. A 0-dBV FSI places no attenuation in front of the ADC and in fact 

means that 1 Vrms will drive the ADC to its maximum rated full scale input voltage (not 

the same as 1 Vrms). This means that noise contributed by the QA403 to a measurement 

will tend to be larger for larger values of FSI. With no input, the noise reported by the 

QA403 is listed below as a function of the FSI setting. Measurements were done with a 

192 kHz sample rate, a 256k FFT and 4 averages. All inputs were shorted. 
 

 FSI, dBV Noise, dBVrms Noise, µVrms  FFT Floor, dBV 

    0      -118   1.3   -150 

    6   -114   2.0   -146 

    12   -110   3.3   -142 

    18   -104   6.1   -136 

    24   -83   71.4   -116 

    30   -83   74.8   -115 

    36   -81   85.0   -115 

    42   -79   117   -110 

 

The noise measurements above were made with the default measurement 

bandwidth of 20 kHz. This is also the noise bandwidth. Noise increases by 3 dB for each 

doubling of noise bandwidth. If we quadruple the maximum value of the measurement 

bandwidth by setting XLOG End Frequency and RMS Measured Stop Frequency to 80 kHz, 

you will see the measured noise go up by 6 dB, as expected. 

 

Analyzer THD vs FSI Margin 
One would normally like to use as much of the ADC's dynamic range as possible 

if having the least analyzer noise contribution is the priority for the measurement. This 

means using the lowest FSI setting possible, applying the maximum allowable signal 
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amplitude to the ADC. However, this can increase ADC distortion. So there is a tradeoff. 

The amount by which the signal voltage is below the FSI setting is the FSI margin. A 

conservative FSI margin is 18 dB, but this sacrifices dynamic range. It is thus useful to 

know what the QA403's own THD is as a function of input signal dBV and FSI dBV in a 

loop back. The data below shows this.  

 

Maximum QA403 output is +18 dBV, so only 4 input signal levels are shown. In 

an ideal world, one might expect THD to be the same for a given FSI margin, but that is 

not always the case in the real world. Measurements with FSI margin of greater than 24 

dB do not make sense; this is obvious from the table. FSI settings too high allow analyzer 

noise to influence THD readings and increase reported THD. 

 

QA403 THD, dB 

 

 Input Amplitude: 0 dBV  6 dBV  12 dBV 18 dBV 

 FSI Margin 

    0 dB   -115  -113  -115  -111 

    6 dB   -119  -116  -119  -113 

   12 dB   -121  -116  -116  -113 

   18 dB   -121  -114  -116  -117 

   24 dB   -108  -109  -113  -112 

 

Gain Measurement 
Gain and frequency response of the amplifier will now be measured. The left 

channel will be measured. Begin by hitting File > New Settings to start with known 

default settings. Make sure that the current or previous measurement has been stopped 

first. If a totally clean slate does not result, hit New Settings again. Connect an 8-Ω load 

resistor to the amplifier. 
 

Measure the gain of the amplifier. 

 Click on the right channel to turn it off. 

 Set the sample rate to 96 kHz. 

 Increment the FFT size to 64k and increment System Averages to 4. 

 Set the full scale input to 18 dBV and Ymin to -140 dBV. 

 Add the measurements Gain dB, RMS Volts, RMS dBV and RMS Pwr Watts. 

 Add the measurements THD % and THD+N %. 

 Click the Gen 1 button, right click and set amplitude to -20 dBV. 

 Click on the GAIN button. 

 Click RUN. 
 

An FFT line appears at 1 kHz and the  Linear Gain Tile will show gain as 28.4 dB 

(i.e, linear voltage gain equals 26.4). 
 

Click on the FFT peak at 1 kHz and see the marker show +8.4 dBV. 
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Go to File > Save Settings. Name the file "Gain.settings" and save it in the 

Measurement Settings folder. 
 

If gain has been measured previously, just hit File > Load Settings and load the 

file Gain.settings from the Measurement Settings folder, then hit RUN. 
 

The same gain measurement results as from the previous run will appear. This 

demonstrates how easy it is to do a measurement at any time if the settings from a 

previous measurement have been loaded. Before hitting RUN, one can make any desired 

modifications to those settings. 
 

 
 

Figure 2: Screen Shot of the Amplifier Gain Measurement 
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The tiles at the top of the display area form a dashboard of settings and readings, 

as shown in the screen shot above. The screen shot is taken by going to File > Save 

Bitmap as ... and choosing the format as png, jpg or bitmap. 
 

This will be your first test of the amplifier, so some additional measurements are 

added to the dashboard in the New Measurements section. This will give an early 

indication of basic amplifier functionality and performance. It may spot troubles, such as 

high hum, high noise, high distortion, etc.) before proceeding to further tests 

 

Frequency Response 

Measure the frequency response of the amplifier. 

 Begin by hitting File > New Settings to start with a clean slate. 

 Turn off the QA40X right channel. 

 Set the sample rate to 192 kHz and Increment the FFT size to 128k. 

 Click on Frequency Response in the Generator section. 

 The Sys: GenEx tile provides the Exponential Frequency Chirp stimulus. 

 Decrement the GenEx amplitude to -20 dBV to feed the amplifier 100 mV. 

 Set the full-scale input to 18 dBV. 

 Set the XLOG range at 10 Hz to 80 kHz. 

 Right click on dBr and select "Set 1 kHz Level to 0 dBr". 
  

 Click RUN. 
 

Go to File > Save Settings. Name the file "Freq Response.settings". 
 

The frequency response of the amplifier is shown over a range of 10 Hz to 80 kHz 

with a large y-axis dB range. Hit "1 to -1" on Y PRESET in the Axis control area. to see the 

frequency response in a  ±1 dB window. The amplifier is seen to be down 0.35 dB at 10 

Hz and 0.1 dB at 20 Hz. The amplifier is down 0.04 dB at 20 kHz and 0.9 dB at 80 kHz. 
 

Go to the Cursors control section and add Cursor 1 by clicking on C1 and center it 

in the plot by clicking on Center. If the Cursor area is not visible on the screen and you 

are on a laptop without a mouse wheel, click the down arrow key to scroll the control 

area down. Similarly, if you have scrolled down and the Run/Stop area is not visible, scroll 

with the up arrow key.  
 

Ignore a warning that performance may suffer with a large FFT. The 128k FFT is 

necessary to measure the response down to 10 Hz. 
 

Move the cursor to 20 Hz by dragging its label to the left. See in the lower left of 

the display that the enunciator indicates the frequency X1 is 20 Hz and that the 

amplitude Y1 is -0.1 dBr. Move the cursor to 20 kHz and see that the response is -0.04 

dBr. Alternatively, invoke Cursor 2 and drag it to 20 kHz and see both the 20-Hz and 20-

kHz responses in the enunciator. 
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Figure 3: Frequency Response Measurement 10 Hz to 80 kHz 
 

Frequency response is down 0.35 dB at 10 Hz, down 0.1 dB at 20 Hz, down 0.03 

dB at 20 kHz, down 0.3 dB at 50 kHz and down 0.9 dB at 80 kHz. 

 

Noise 
Here the noise of the amplifier with no input will be measured. Disconnect the 

amplifier input from the QA40X and ground the input of the amplifier with an RCA 

shorting plug (or with an XLR grounding plug with pins 1, 2 and 3 connected together). 

The noise will be first measured with no weighting in the default 20-kHz bandwidth and 

then with A weighting. 
 

 Ground the input of the amplifier. Do this right at the RCA input jack without any 

other ground connected at the jack. It is important to eliminate the possibility of ground 

loops for this sensitive test. 
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 Begin by hitting File > New Settings to start with a clean slate. 

 Turn off the right channel. 

 Set the full scale input to 0 dBV and set the sample rate to 192 kHz. 

 Set the FFT size to 128k with 10 averages and a Hann window. 

 In New Measurements select RMS Volts. 

 Set Ymin to -160 dBV and Ymax to 0 dBV. 

 Hit RUN. 
 

Go to File > Save Settings. Name the file "Noise.settings". 
 

The large FFT size and 10 averages yields the best possible result, but it takes 

time - about 18 seconds for each round of 10 measurements. Wait for 2 rounds to 

complete, for a total of 36 seconds. An FFT of 64k with 4 averages will provide 

acceptable results. Keep the sample rate at 192 kHz to minimize the noise measurement 

time and also to provide the best FFT presentation at low frequencies like 60 Hz. Large 

FFTs are required to make good presentations of results at low frequencies. 
 

The display for the measurement in Figure 4 shows hum and noise with an RMS 

total of 21 µV in a 20 kHz bandwidth. The only predominant hum-related line was at 120 

Hz at -104 dBV as indicated by the marker placed on the 120-Hz line. Other lines were in 

the vicinity of -130 dBV or less. The band of random noise is centered at about -132 dBV.  

 

 
 

Figure 4: Amplifier Un-weighted Output Noise 
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This amplifier shows quite a low amount of hum and its harmonics, but to further 

reduce the influence of hum and its harmonics and get a better picture of the audible 

noise, hit the A Weighting button in the Weighting section of the control area.  
 

Load the file "Noise.settings". 

hit the A Weighting button. 

Hit RUN. 

Save the measurement file as "Noise A wtd.settings" 
 

The RMS noise drops to 15.8 µV, with the 120-Hz line falling to -121 dBV. The 

difference in the frequency response of the noise due to A weighting is easily apparent in 

Figure 4. Dividing 15.8 µV by 2.83 volts yields A-weighted SNR of 115 dB. The power 

supply for this version of the amplifier is in a separate chassis, reducing hum and line 

harmonics. Most amplifier implementations will have more hum and line harmonics due 

to the power supply being in the same chassis. 

 

 
 

Figure 5: A-weighted Amplifier Output Noise 

 

Right click on the dBV button and enter the gain of the amplifier as 28.6 dB. The 

A-weighted input-referred noise is shown as 0.585 µV or 585 nV.  
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User-defined Noise Weighting 
Notice that in the Weighting section there are two weighting selections labeled 

USER1 and USER2. These allow user-defined weighting of results by entering a file that 

lists frequencies and their corresponding weighting attenuation. Two examples of such 

weighting are the RIAA phono record and playback equalization curves. Here we will 

demonstrate this feature by entering the ITU R 468 noise weighting curve as an 

alternative to A weighting [4]. The file should be in the form of frequency followed by a 

comma, a space and a dB amount of attenuation as shown below for an ITU R 468 file.  
 

Note that the ITU R 468 weighting curve is specified as 0 dB at 1 kHz, as shown 

below, but it has high-frequency regions where there is actually gain, as designated by a 

minus sign in the file listing. The gain peaks at 6300 Hz with a value of 12.2 dB. At low 

frequencies, the weighting falls at just 6 dB/octave. At frequencies over 10 kHz the 

weighting falls off at an increasing slope with frequency, starting at about 12 dB/octave 

and increasing to over 24 dB/octave at 20 kHz. The weighting files can be conveniently 

stored in the folder QuantAsylum > QA40X > UserWeighting.  
 

It should be noted that ITU R 468 noise measurement is intended to be made 

with a quasi-peak detector in its standard implementation for professional audio, which 

will not happen here. However, the Dolby CCIR/ARM (now called ITU-R ARM) 

measurement method is intended for use with a less-expensive average detector. Its 

weighting function is that of ITU R 468 with the exception that its zero-dB point is shifted 

from 1 kHz to 2 kHz [4]. Because ITU R 468 is 0 dB at 1 kHz and CCIR/ARM is -5.6 dB at 2 

kHz, the CCIR/ARM curve values are obtained by adding 5.6 dB to all values in the ITU R 

468 table below. 
 

 31.5, 29.9 

 63.0, 23.9 

 100, 19.8 

 200, 13.8 

 400, 7.8 

 800, 1.9 

 1000, 0.0 

 2000, -5.6 

 4000, -10.5 

 5000, -11.7 

 6300, -12.2 

 7100, -12.0 

 8000, -11.4 

 9000, -10.1 

 10000, -8.1 

 12500, 0.0 

 14000, 5.3 

 16000, 11.7 

 20000, 22.2 
 

 Connect the output of the QA40X to the amplifier input. 

 Go to File > Load Settings. and load the file "Noise.settings". 
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 Change the full scale input to 24 dBV. 

 Change FFT to 64k, Averages to 4. 

 Set Ymin to -80 dBV. 

 Select White Noise in the Generators section. Retain the default level of -12 dBV. 

 Click on USER1 and enter the file ITU R 468 in the dialog box. Select it from the  

 User Weighting folder. 

 Double click on the desired file and hit OK. 

 Hit RUN. 
  

 See a flat noise frequency response at about -30 dBV and with an RMS total of 60 

mVrms. Turn on A Weighting and see the A weighting frequency response with a peak of 

about -28 dBV at between 2 and 3 kHz, and RMS noise of 62 mVrms. Turn off A 

weighting and select USER1 and see the ITU R 468 response with a peak of -18 dBV 

around 6-7 kHz and RMS noise of about 220 mVrms. 
 

The aggressive FFT settings provide a cleaner noise frequency response profile. 

An orange note indicating the weighting(s) in effect will appear in orange in the upper 

left display area. You can enter more than one weighting, e.g. A and USER1, even though 

it does not make sense here. Different weighting can be chosen while the measurement 

is in progress. To change the USER1 weighting file, click USER1 to off and then right click 

USER1 to get back to the USER1 file selection dialog box. 
 

User-defined weighting can also be used to enter other weighting of responses 

like a response to correct the attenuation of a passive twin-T notch filter at the harmonic 

frequencies. These losses are approximately 9 dB and 5 dB at the second and third 

harmonic frequencies, so are significant in affecting the results of a THD measurement 

that uses a passive twin-T notch filter in front of the QA40X. Such an arrangement allows 

greater distortion-measurement dynamic range by using the 0 dB full scale input setting. 

Other useful weightings include a pink noise characteristic, band pass characteristics, etc. 

If you want to know the effective A-weighted noise of a moving coil preamp after RIAA 

equalization, you would invoke both A weighting and RIAA weighting. 

 

SNR 
Signal-to-Noise Ratio (SNR) will be measured here. It is essentially a 

measurement of the amplifier noise (not including harmonics) as described above, with 

the output noise voltage divided by an output signal voltage of 2.83 Vrms, 

corresponding to 1 W into 8 Ω. 2.83 Vrms is +9.0 dBV, so if the amplifier has 28 dB gain, 

a -19 dBV input signal will yield a 1-Watt output into 8 Ω.  
 

The SNR is usually measured in a defined bandwidth, and is often weighted. Un-

weighted SNR will often be measured in a 20-kHz or 80-kHz bandwidth. Weighted noise 

will usually be measured with the A-weighting frequency curve, which attenuates the 

measurement at low and high frequencies to account for the way that hearing sensitivity 

varies with frequency.  
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It should be pointed out that the frequency response of hearing sensitivity is not 

the same for a single tone as opposed to narrowband noise [4]. A weighting was actually 

developed using the audibility of single tones, so it is rather imperfect. The QA40X 

includes A-weighting and C-weighting as options. It can also apply weighting in 

accordance with a weighting file provided by the user, designated USER1 and USER2. 

Connect the output of the QA40X to the input of the amplifier. Connect the input of the 

amplifier to the output of the QA40X. 
 

Go to File > LOAD Settings, and load the file "Noise.Settings". 

 Set Full Scale Input to 18 dBV. 

 Push the SNR button and the SNR tile will appear. 

 Click on Gen 1, then right-click and set amplitude to -19 dBV,  

 Set Amplitude Knob Sensitivity to 0.2 dB. 

 Add the RMS Pwr Watts, RMS Volts and RMS dBV measurements. 

 Reduce FFT size to 64k and Averages to 4. 

 Increase Ymax to +20 dBV, and increase Ymin to -140 dBV. 

 Hit RUN. 
 

 Increment/decrement the Gen 1 level to achieve 1 Watt (+9 dBV) within ±0.5 dB. 

Go to File > Save Settings. Name the file "SNR.settings". 
 

 
 

Figure 6: Un-weighted SNR in 20-kHz Bandwidth 
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Observe the un-weighted SNR as 100 dB for this amplifier with bandwidth of 20 

kHz. Notice that the noise floor is centered around -127 dBV. Notice that 60-Hz hum is 

at -113 dBV, 122 dB below 1 Watt. See also a 3rd harmonic line at -106 dBV, 115 dB 

below 1 Watt, corresponding to 0.00018% harmonic distortion. Press the A weighting 

button and see the SNR increase to 102 dB.  
 

Go to File > Save Settings. Name the file "SNR A wtd.settings". 
 

Sometimes the un-weighted SNR in an 80-kHz bandwidth is quoted. This can be 

measured as follows: turn off the A weighting. Right click on XLOG and set the end 

frequency to 80 kHz. Right click on RMS and set the stop frequency to 80 kHz. The un-

weighted 80-kHz SNR is reported as 94 dB. 

 

 
 

Figure 7: A-weighted SNR 
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Noise Density 
Input-referred noise density is expressed in nV/√Hz. It is the RMS output noise 

over a known frequency range divided by the amplifier gain. This is a special mode of the 

analyzer for noise measurements, and it shouldn't be used for measuring tones. Consider 

an amplifier whose output noise is 15 µV in a 20-kHz bandwidth and whose gain is 26 

dB. Input-referred noise is 0.75 µV or 750 nV. A 20-kHz bandwidth contains 141 √Hz. 

Dividing 750 nV by 141 √Hz yields 5.3 nV/√Hz. This is quite good for a power amplifier. 

For context, the input noise for a moving coil preamplifier should be about 1 nV/√Hz or 

less. If one right clicks on the dBV button in the Axis section a dialog box will come up 

where the units for the Y axis can be selected. One of those selections is Rt Hz.  Short 

the input(s) to the amplifier. 
 

Go to File > Load Settings and load the file Noise.settings. 

 Click on dBV in the Axis settings. 

 Right click on dBV, and in the dialog select dBV and check Rt Hz. 

 Set input gain to that of the amplifier, here 28.6 dB. 

 Adjust Ymin to -180 dBV, which is shown as 1.0 nV/√Hz on the right axis. 

 Hit RUN. 

 

 
 

Figure 8: Input-referred Noise Density 
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Go to File > Save Settings and save this setup file as "Noise Density.settings". 
 

The noise density is displayed in Figure 8 on the right-side Y axis in nV/√Hz, with 

that value being properly referred with respect to the input by the entered amplifier gain. 

The aggressive FFT settings provide a cleaner noise frequency response profile. This 

amplifier exhibits input-referred noise of about 7 nV/√Hz, as seen by the body of the 

noise floor and ignoring the 60-Hz hum and harmonics.  

 

THD and THD+N 
The THD and THD+N of the left channel of the amplifier will be measured at 1 

kHz with the amplifier connected to an 8-Ω load . Note that for measurements with a 4-

Ω load (or other load not the 8-Ω default) the load impedance in the dBV settings must 

be set accordingly for proper calculation of power. 
 

Connect the left channel output of the QA40X to the left channel input of the amplifier. 

Ground the right channel input of the amplifier. 

Connect the left channel output of the amplifier (DUT) to an 8-Ω load. 

Connect the left channel output of the DUT to the left channel input of the QA40X. 
 

 Start fresh by entering File>New Settings. 

 Click RIGHT channel to off in the Display section. 

 Set the Sample Rate to 192 kHz. 

 Set FFT size to 64k, Averages to 4, and Window to Hann. 

 Push THD and THD+N buttons in Measurements; right click THD to note options. 

 Add the measurements THD %, THD+N %. 

 Add the measurements RMS Volts, RMS dBV and RMS Pwr Watts. 

 Push Gen 1 button if not enabled; right click and set amplitude to -20 dBV. 

 Set Gen 1 Amplitude Knob Sensitivity to 0.2 dB. 

 Hit RUN. 
 

The display will show a fundamental line at 1 kHz, and other lines at harmonics, 

hum frequencies, etc. The 1-kHz line will likely be between 0 and +10 dBV depending on 

amplifier gain. Here it is +8.6 dBV because the gain of this amplifier is 28.6 dB. This 

corresponds to 900 mW. The noise floor is at about -115 dBV. Change the full scale input 

(FSI) from the default 42 dBV to 18 dBV. The noise floor drops to about -127 dBV, since 

this reduces any noise contribution due to the analyzer when FSI is 42 dBV.  
 

Increment or decrement Gen 1 until the power is about 1 watt. THD and THD+N 

now read -102 dB (0.0002 %) and -87 dB (0.0011 %). Note the Gen 1 input level is at -

19.40 dBV. 
 

Return the Full Scale Input (input attenuator) to 42 dBV (the default). 
 

Go to File > Save Settings and save this setup file as "THD_1 1_W.settings". 
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Increase the power level to about 10 Watts by incrementing the level of Gen 1 

with its up arrow. Output voltage is now 8.9 Vrms. THD is now 0.00027% and THD+N is 

now at 0.0014%. Increase Ymax to +40 dBV. Increase the power level to about 100 W. 

THD is now 0.00019 % and THD+N is now 0.00052 %. Increase amplifier power to its 

rated 145 W. THD is now 0.00018 % and THD+N is now 0.00048%. Note that the rated 

power of 140 W is obtained with a Gen 1 input level of +1.9 dBV. 

 

 
 

Figure 9: THD-1 Measurement at 1 Watt 

 

THD vs Output Power into 8-Ω and 4-Ω Loads  
Now push the amplifier to its power limit at the onset of clipping at 1 kHz. Start 

at approximately the rated power of 140 W into 8-Ω  by setting the Gen 1 signal level to 

+1.9 dBV. Note that for measurements with a 4-Ω load (or other load not the 8-Ω 

default) the load impedance in the dBV settings must be set accordingly for proper 

calculation of power. Note that this measurement does not conform to the FTC power 
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rating measurement standard because there is no preconditioning, the test here is done 

with signal bursts and it is done with only one channel operating. 
 

Go to File > Load Settings and load the file "THD_1 1_W.settings". 

Increase the Gen 1 setting to +1.9 dBV, corresponding to 140 W into 8-Ω. 

Hit RUN. 
 

Go to File > Save Settings and save this setup file as "THD_1 140_W.settings". 
 

THD-1 reads 0.00013%. Increment the Gen 1 level until you see a marked increase 

in THD and the FFT harmonic lines, approaching but not exceeding 1%. At 175 W, with 

Gen 1 level at +2.90 dBV soft clipping is apparent with THD at 0.034 %. A further increase 

of 0.2 dB pushes THD above 1 %. Clipping power is thus about 175 W.  
 

Now push the amplifier to its power limit with a 4-Ω  at the onset of clipping at 1 

kHz. An ideal amplifier will double its rated power with a 4-Ω load with the same relative 

amount of margin against clipping as with an 8-Ω load. This will not be the case for real 

amplifiers due to power supply sag at the higher current demand. Connect a 4-Ω load to 

the amplifier. Start at approximately 70% of twice its 8-Ω rated power, or 200 W into 4-Ω  

by setting the Gen 1 signal level to +0.8 dBV. Connect a 4-Ω load to the amplifier. 
 

Go to File > Load Settings and load the file "THD_1 140_W.settings". 

Right click the dBV button and set the load impedance to 4 Ω. 

Change the Gen 1 setting to +0.8 dBV, corresponding to about 200 W into 4-Ω. 

Hit RUN. 
 

Go to File > Save Settings and save this setup file as "THD_1 4_Ohm.settings". 
 

Observe a reported power level of about 200 W with THD of about 0.00017%. 

Increment the Gen 1 level until you see a marked increase in THD and the FFT harmonic 

lines, approaching but not exceeding 1%. At 280 W, with the Gen 1 level at +2.0 dBV, 

soft clipping is apparent with THD at less than 0.1 %. Clipping power is about 280 W. 

 

Burst Power into 4-Ω and 2-Ω Loads 
You can have the QA40X do a test with a single burst, allowing a very small 

average power duty cycle. Set the sample rate and FFT size and initiate a single 

measurement burst by hitting CTRL+space. The measurement will be made at 1 kHz. If 

you select a sample rate of 192 kHz and a very small FFT size of only 2k, the burst will 

last only about 40 ms. In this case, the result of the measurement will largely reflect the 

burst power of the amplifier achievable before the power supply sags. For the test below, 

the BC-1 was equipped with 40,000 µF for each power supply rail.  
 

This test will also reflect the performance of the amplifier without any significant 

amount of thermal output stage bias change. If the output of the amplifier is captured 

on a DSO or if you shift to the Time Domain display on the QA403, near-instantaneous 

clipping performance can be safely observed. Finally, measuring an amplifier when 
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driving a 2-Ω load can be done safely. Such brief drive signals can also be useful in safely 

evaluating protection circuits and evaluating peak output current capability. Connect a 4-

Ω load to the amplifier for this test. 
 

 Start fresh by entering File>New Settings. 

 Set Full Scale Input to 42 dBV. 

 Click RIGHT channel to off. 

 Set Sample Rate to 192 kHz, FFT size to 2k and FFT window to Hann. 

 Push the THD button. 

 Push Gen 1 button if not enabled; right click and set amplitude to +2.0 dBV. 

 Set Gen 1 Amplitude Knob Sensitivity to 0.1 dB. 

Right click the dBV button and set the load impedance to 4 Ω. 

 In Add Measurements, select RMS Pwr Watts, RMS dBV and THD%. 

 Set Ymin to -120 dBV and set Ymax to +40 dBV. 

 Hit CTRL+space. 
 

Go to File > Save Settings and save this setup file as "Burst Power.settings". 
 

 
 

Figure 10: Burst Power into 4-Ω Load at 1 kHz 

 

A single measurement will be run, with reported power of 280 W and THD below 

0.001%. Increase the Gen1 amplitude in 0.1-dB increments, hitting CRTL+Space with each 

increment, until the THD reading rises steeply, indicating the onset of clipping.  
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For this amplifier that occurs at an input amplitude of about +2.9 dBV, where 

burst power reported is 350 W and THD-1 is still below 0.001%. Distortion rises sharply 

above this amplitude. This will be the maximum burst power of the amplifier with a 4-Ω 

load. This is considerably higher than the clipping power of 280 W reported in the 

conventional measurements above. The maximum output voltage in this test at 346 W 

was +31.4 dBV, just a hair below the 32 dBV maximum input of the QA403. This is an 

example of a test where use of an external attenuator can be a good idea. 
 

We will now punish this modest amplifier, rated at 140-W, 8-Ω, by loading it with 

a 2-Ω load. First set the Gen1 output amplitude to 0.5 dBV to check amplifier stability 

driving a 2-Ω load. This setting will deliver 200 W into the 4-Ω load. Connect the 2-Ω 

load and set the dBV load impedance to 2 Ω. Hit CTRL+space. The amplifier delivers 398 

W, a small reduction from twice 400 W, which is a good sign. THD-1 is 0.007%. At 426 W, 

THD-1 has risen to 0.1% and we will stop there. Current limiting has probably come into 

play at this point. 

 

Burst performance into 2 Ω loads can matter. Some loudspeakers can dip that 

low. Also, if the amplifier is bridged with a 4-Ω load, the amplifier on each side of the 

bridge will effectively see a 2-Ω load. This modest amplifier might not last long in such a 

bridged arrangement into 4 Ω, however. 

 

THD vs Frequency 
Now drop the power to approximately 1 Watt and measure its THD as a function 

of frequency up to 20 kHz by incrementing the Gen 1 frequency. After the 1-Watt tests, 

we will raise the power to 125 Watts and measure THD as a function of frequency.  
 

 Start fresh by entering File>New Settings. 

 Set Full Scale Input to 42 dBV. 

 Click RIGHT channel to off. 

 Set Sample Rate to 192 kHz, FFT size to 64k, averages to 4, FFT window to Hann. 

 Push Gen 1 button; right click and set amplitude to -12.6 dBV. 

 Set Gen 1 Frequency Knob Sens. to 1/3 octave,  Amplitude Knob Sens. to 0.2 dB. 

 Click the THD button. 

 In Add Measurements, select RMS Pwr Watts, RMS dBV. 

 Add the measurements THD dB, THD+N dB, THD% and THD+N%. 

 Right click on XLOG and increase its end frequency to 80 kHz. 

 Right click on THD and increase its stop frequency to 85 kHz. 

 Hit RUN. 
 

Go to File > Save Settings and save this file as "THD vs Freq.settings". 
 

Or load the file "THD vs Freq.settings"  if it already exists. 
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 The Gen 1 amplitude setting of -12.6 dBV puts the output power at about 5 W. 

THD-1 for this amplifier reads -106 dB, or about 0.0005%. The 1-kHz fundamental is at 

16 dBV. The harmonic spectrum can be seen out to 80 kHz, but there is not much there 

other than some 3rd and 5th harmonic lines. 
 

Increment the Gen 1 frequency to 20 kHz in 1/3-octave steps and watch the THD 

and harmonic content increase. At 10 kHz, harmonic lines can be seen out to 80 kHz, and 

THD is 0.0024 %. As expected, 3rd and 5th exhibit the highest amplitude. At 20 kHz, THD 

is up to 0.0038 % and the 2nd, 3rd and 4th harmonic lines are visible. 
 

Go to File > Save Settings and save this file as "THD_20 5_W.settings". 

 

 
 

Figure 11: THD-20 Spectrum at 5 Watts 

 

Note that if the fundamental frequency is incremented above about 40 kHz, the 

THD reading goes down precipitously, as a result of the second and higher harmonics 

being no longer in the measurement range. 
 

 Now we will measure THD at a power of 125 Watts. Set the full scale input to 42 

dBV, return the frequency to 1 kHz and increment Gen 1 until the output power is 140 

watts. The output level is at +30 dBV and THD-1 reads 0.0002 %.  
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Increment the frequency to 10 kHz in 1/3-octave steps and watch the THD and 

harmonic content increase. see THD rise to THD-10 of 0.0015 %. Harmonics up to the 8th 

at 80 kHz are clearly visible. 
 

Increase the frequency to 20 kHz and see THD rise to THD-20 of 0.0037 %. 

Harmonics up to the 4th at 80 kHz are clearly shown. The THD measurement floor is at 

about -115 dB, about 145 dB below the fundamental. 
 

 
 

Figure 12: THD-20 Spectrum at 125 Watts 

 

Go to File > Save Settings and save this file as "THD_20 125_W.settings". 

 

THD vs Frequency vs Output Power 
In this test, THD vs. frequency is measured for several different power levels. This 

will be accomplished with one of the automated tests below under "Automated Tests". If 

this measurement is done manually, it must be executed at individual frequencies by 
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measuring THD at different power levels, making note of THD as power level is 

increased. 

 

THD Visualizers 
The QA40X software includes some Visualizers that present measured data in 

different ways that can be quite helpful. Among the visualizers are two for THD - the 

Bargraph Display and the Residual Display. The former provides a bargraph that shows 

the relative amplitudes of the THD harmonics. The latter provides an oscilloscope-like 

voltage vs time display of the distortion residual, just as does the residual output of a 

conventional distortion analyzer. 

 

 
 

Figure 13: THD-1 Bargraph Display at 136 Watts 

 

Load the file "THD_1 1_Watt .settings". The frequency will be at 1 kHz. Set the Gen 

1 level to +1.8 dBV to obtain an output power level of about 136 Watts. Hit RUN. THD-1 

reads about 0.0002 %. Distortion is low, but with a rich harmonic structure as seen on the 

FFT. 
 

Go to File > Save Settings and save this setup file as "THD_1 136_W.settings". 
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Stop the measurement and go to Visualizers > THD Bargraph Display. A bargraph 

comes up displaying harmonics H2 through H10, all referenced to the fundamental at 0 

dB. The dB level is shown at the top of each bar. Right click on the bargraph and select 

"Save Image as ..." and save the image in the chosen format to a folder. 
 

Close the bargraph display and increase the Gen 1 level until the indicated power 

level is about 162 Watts at about +2.6 dBV and clipping is occurring.  
 

Go to File > Save Settings and save this setup file as "THD_1 162_W.settings". 
 

Go to Visualizers > Residual Display. A residual signal voltage display of the 

fundamental and residual versus time will be displayed. Signal voltage is shown on the 

left Y axis and residual signal voltage is shown on the right axis. The waveforms are too 

dense to see. Drag the plot from upper left to lower right to zoom in to about 4 cycles of 

the fundamental. Clipping at the top of the waveform is evident. The signal voltage has a 

peak value of about 45 volts and the residual has a peak value of about 1 V.  

 

 

 
 

Figure 14: THD-1 Distortion Residual at 162 Watts Clipping 

 

Close the residual display and go to the oscilloscope visualizer. Zoom in to about 

3 cycles of the fundamental. The output waveform will be displayed, with the positive 

peak exhibiting clipping. 
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Figure 15: Oscilloscope Display Showing Hard Clipping of the Amplifier 

 

GenEx Burst Waveform 
Measurements are made with a stimulus signal burst during which FFT data 

points are taken. The bursts are followed by a signal-off calculation interval. Depending 

on the settings for sampling rate and FFT size, the duty cycle of the repeated 

measurements can change, but is often in the range of 70% to 90%. The duration of the 

burst is approximately the ratio of the FFT size to the sample rate. A 32-k FFT with a 

sample rate of 48 kHz will have a burst of about 680 ms. For a given FFT size, a higher 

sample rate will result in a shorter burst interval. A typical 64k FFT with a 96 kHz sample 

rate was measured to have a burst duration of about 720 ms and a subsequent off 

interval of about 180 ms, for a total measurement time of 900 ms and a duty cycle of 

80%. 
 

The burst duty cycle influences how hot the load resistor gets and how much the 

amplifier output transistor junction and heat sink temperatures rise during repeated 

measurements. A smaller duty cycle allows the use of a load resistor with a lower power 

rating. A smaller duty cycle also allows for less power transistor heating and less output 

stage bias change during the measurements (which can influence distortion readings). 

The duty cycle of repeated measurements can be reduced by introducing a pause 

interval during the signal-off time. This can be done by going to Edit > Settings > Pause 

Acquisitions and entering a pause time of up to 2 seconds. This can reduce a typical 

measurement duty cycle to as little as about 25%. An even smaller duty cycle and burst 

duration can be had with a 32k FFT at a 192 kHz sample rate. 
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You can also have the QA40X do a test with a single burst, allowing an almost 

arbitrarily small duty cycle. After you set the sample rate and FFT size, you can initiate a 

single measurement burst by hitting CTRL+space. If you select a sample rate of 48 kHz 

and a very small FFT size of only 2k, a 1-kHz burst will last only about 40 ms. In this case, 

the result of the measurement will largely reflect the burst power of the amplifier 

achievable before the power supply sags. This will also reflect the performance of the 

amplifier without any significant amount of thermal output stage bias change. If the 

output of the amplifier is captured on a DSO, then near-instantaneous clipping 

performance can be safely observed. Finally, measuring an amplifier when driving a 2-Ω 

load safely can also be done. Such brief drive signals can also be useful in safely 

evaluating protection circuits and evaluating peak output current capability. 
 

Below is an image of a 350-ms burst carried out during a frequency response 

measurement using the oscilloscope visualizer. 

 

 
 

Figure 16: A GenEx Burst Waveform During a Frequency Response Measurement 

 

CCIF 19 + 20 kHz (ITU-T) 
The two-tone CCIF IM measurement using equal-amplitude tones at 19 kHz and 

20 kHz will be made here. This measurement of high-frequency intermodulation 

distortion is especially attractive because the IM products to be measured are all in-band 

at frequencies below 20 kHz (IM products exist above the audio band, but they are not 

of interest in this test). Those are usually centered in the vicinity of 39 kHz. An advantage 

of the two-tone test is that the individual tones need not be of extremely low distortion, 
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as with THD measurements, since IM products are being measured, not harmonic 

products. These observations also apply to the SMPTE IM tests further below. 
 

This test will be carried out with a peak stimulus voltage that is the same as the 

peak voltage of a sine wave that is the equivalent test power of the amplifier into 8 Ω. 

Even-order IM products will be at 1 kHz, 3 kHz, etc., while odd-order IM products will 

surround the twin tones of 19 kHz and 20 kHz, at frequencies like 18, 21, 17, 22 kHz, etc.. 

Some prefer to use 18.5-kHz and 19.5-kHz tones so that high odd-order products do not 

overlap any even-order IM products. 
 

This test is especially important for testing class D amplifier high-frequency 

performance, since THD is virtually useless when most if not all of the harmonics may lie 

at frequencies above the output low-pass filter frequency. With this test, the IM products 

lie in-band and they accurately depict the performance of amplifiers that have significant 

roll-off above the audio band. 
 

Here the BC-1 amplifier will be measured at 125 Watts equivalent power, 

corresponding to 31.6 Vrms or 44.7 Vpk into 8 Ω. This means that each tone should be 

22.35 Vpk, corresponding to 15.81 Vrms, which corresponds to 24.0 dBV. With amplifier 

gain of 28.4 dB, each tone from Gen 1 and Gen 2 should have amplitude of -4.4 dBV. 
 

 Hit File > New Settings to start with a clean slate. 

 Set Full Scale Input to 42 dBV. 

 Turn off the right channel. 

 Set Gen 1 to 19 kHz at -4.4 dBV. 

 Set Gen 2 to 20 kHz at -4.4 dBV. 

 Add Pk dBV, Pk Vrms and RMS Power W measurements. 

 Add Sys: FFT and Sys: Averages. 

 Set the sample rate to 192 kHz. 

 Set the FFT size to 128k with 4 averages. 

 Select the Hann FFT window. 

 Set XLOG for 500 Hz to 45 kHz. 

 Go to the dBV dialog and set Load Impedance to 8 Ω. 

 Hit RUN. 
 

Go to File > Save Settings. Name the file "CCIF 19_20.settings". 
 

 Increase Ymin to -140 dBV and increase Ymax to +30 dBV. 
 

The display shows the 19 and 20-kHz tones, each at +24.0 dBV, surrounded by IM 

products. Note the 39-kHz IM even-order frequency sum product at -65 dBV also 

surrounded by other IM products. It is down 89 dB from each of the 19 kHz and 20 kHz 

tones. The even-order frequency difference IM product at 1 kHz at -85.5 dBV, is down 

110 dB from each tone.  
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The two tones are at +24 dBV and they are surrounded by sideband distortion 

products every 1 kHz away. The 3rd-order product at 18 kHz is at -88 dBV, putting it 

down about 112 dB from each tone. The 5th-order product at 17 kHz is at -97 dBV, 

putting it down 121 dB from the tones. The 7th-order product at 16 kHz is at -98 dBV, 

putting it down 122 dB from the tones. The relative values of the distortion products with 

respect to the tones can be easily seen by hitting the dBr button and selecting the 

display peak as the 0 dBr reference. 

 

 
 

Figure 17: CCIF 19+20 kHz Spectrum at 125 Watts Equivalent 

 

With the amplifier operating at an equivalent 125 Watts, note that the QA40X is 

reporting RMS power of 64.8 Watts. This means for a test with two equal tones, the 

actual power is 52 % of the power that corresponds to the peak voltage swing with the 

two tones. This means, for example, if you are testing a 100-Watt amplifier at its rated 

power, then you should adjust the levels of the two tones to achieve a target value of 52 

Watts as reported by the QA40X. Put another way, each tone should be down by 5.7 dB 

from the level that one tone alone would produce the desired effective power level. 
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SMPTE IM 60 and 7000 Hz 
The SMPTE IM test is a low-frequency intermodulation distortion test using two 

tones at 60 and 7000 Hz in a 4:1 ratio. The tone amplitudes thus differ by 12 dB. The 

larger low-frequency tone at 60 Hz modulates the gain seen by the 7000-Hz high-

frequency tone (the carrier) by way of the amplifier nonlinearity. This results in distortion 

product sidebands that surround the 7 kHz carrier at intervals of 60 Hz. The sidebands of 

greatest interest are those 60 Hz and 120 Hz away from the carrier, representing the 

2nd-order and 3rd-order products, respectively. 
 

This test will be carried out with a peak amplifier output voltage corresponding to 

the test power for the amplifier into 8 Ω. The BC-1 will be tested at equivalent power 

here of 125-W. That corresponds to a sine wave of 31.6 Vrms or 44.7 Vpk into 8 Ω. The 

low- and high-frequency tones should be 35.76 and 8.94 Vpk, respectively. These, in turn, 

correspond to 25.29 Vrms (28.0 dBV ) and 6.32 Vrms (16.0 dBV). With amplifier gain of 

28.4 dB, the Gen 1 and Gen 2 signal levels should be -0.4 dBV and -12.4 dBV. 
 

 Begin by hitting File > New Settings to start with a clean slate. 

 Set Full Scale Input to 42 dBV. 

 Turn off the right channel. 

 Set Gen 1 to 60 Hz at -0.4 dBV. 

 Set Gen 2 to 7 kHz at -12.4 dBV. 

 Add Pk dBV, Pk Vrms and RMS Power Watts measurements. 

 Add Sys: FFT and Sys: Averages. 

 Set the sample rate to 96 kHz. 

 Set the FFT size to 64k with 4 averages. 

 Select Hann FFT window. 

 Go to the dBV dialog and set Load Impedance to 8 Ω. 

 Set Ymax to +30 dBV and Ymin to -120 dBV. 

 Hit RUN. 
 

Go to File > Save Settings. Name the file "SMPTE IM.settings". 
 

 The 60-Hz tone amplifier output at +28.2 dBV and the 7 kHz tone at +16.2 dBV. 

Reported amplifier RMS power is 87.1 Watts. The rated power of this amplifier is 125 

Watts. This is 3.1 dB higher than the current reported level. 
 

Zoom in to see IM products surrounding 7 kHz at 60-Hz intervals. The even-order 

products 60 Hz away from the carrier are at -88 dBV and -87 dBV, respectively, down 116 

and 115 dB down from the 60 Hz tone. The odd-order products 120 Hz away from the 

carrier at 6880 and 7120 Hz are both at -95 dBV, 123 dB down from the 60-Hz tone. 
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Figure 18: SMPTE IM 60 and 7000 Hz Spectrum at 125 Watts Equivalent 

 

Multitone IM 
In this test a large number of tones at different frequencies will be applied to the 

DUT in order to stimulate the production of many intermodulation products. Those 

intermodulation products will mainly appear in the frequency space between the tones 

where the FFT noise floor will be. The IM product lines may or may not poke above the 

FFT noise floor, depending on their amplitude and the noise level. For this test it is 

important that the FFT noise floor is minimized, which means larger FFT sizes. 
 

In the test illustrated below, the multitone stimulus is set for 1 tone per octave. 

There are 10 octaves in the span 20 Hz to 20 kHz. This setting will thus produce 11 tones 

over the frequency range from 20 Hz to 20 kHz, all of whose peak values will add in-

phase in the worst case. For example, if the value of each tone applied to the amplifier is 

only 14 mV peak (-40 dBV RMS), the maximum peak value applied to the amplifier will 

be 11 times that, or 140 mVpk. If the amplifier gain is 28.4 dB (factor of 26.4), the output 

will be 4.7 Vpk, corresponding to the peak voltage of a 1.4-Watt sine wave into 8 Ω.  
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The multitone level specified in the dialog box is the total RMS level, meaning the 

sum of all of the tones added on a power basis. A greater number of tones will mean a 

lower amplitude for each tone. For reference, with RMStotal = -20 dBV, individual tone 

amplitudes for 1, 2 and 3 tones per octave, are 31.6 mV, 22.3 mV and 18.2 mVrms, 

respectively. The peak value for each tone at 1 tone/octave is 44.7 mVpk, so 11 tones 

creates 492 mVpk. In the case here, with amplifier gain of 26.4, the multitone voltage for 

1 tone/octave and RMStotal setting of -20 dBV is 13.0 volts peak.  
 

It is instructive to calculate the peak voltage of the multitone waveform as a 

function of the number of tones per octave for a given total RMS value of the tones. 

From this the crest factor of the multitone signal can be determined. Well-recorded 

music with little compression can have a crest factor exceeding 15 dB, while a sine wave 

has a crest factor of only 0 dB. This is an important difference for testing with sine waves 

as compared to the real world of music.  
 

For a multitone RMS total of -20 dBV, the individual tone levels are shown below 

as a function of number of tones per octave. The level of each tone decreases as the 

number of tones increases. In going from 1 to 2 tones/octave, the amplitude falls by 3 

dB. Going from 2 to3 tones/octave drops the tone values by 1.8 dB. The peak voltage of 

the waveform after multiplication by the number of tones  and the RMS and dBV values 

of a sine wave with the same peak value are shown. The difference in equivalent dBV of 

the waveform and the multitone RMS total dBV is the crest factor.  

 

 Tones/      tone RMS     peak  equiv     equiv Crest 

 octave      dBV    mV      mV  RMS      dBV  Factor   

   1    -30.0  31.6      492  348       -9.2 10.8 dB 

   2    -33.0  22.4      665  470       -6.6 13.4 dB  

   3    -34.8  18.2      798  564       -5.0 15.0 dB  

   4    -36.1  15.7      910  644       -3.8 16.2 dB  

   5    -37.0  14.1      1017 719       -2.9 17.1 dB  

 

Table 1: Multitone Peak Signal Swings and Crest Factor 

 

To test the amplifier at 50 Watts equivalent, corresponding to 28.3 Vpk into 8 Ω, 

the amplitude of the multitone signal should be 28.3 Vpk. For an amplifier with a gain of 

26.4, the amplitude of the test signal should be 1.07 Vpk. If testing with one tone per 

octave and an RMS total setting of -20 dBV is selected, the amplitude of the test signal 

will be 492 mVpk. This is less by a factor of 2.17 than 1.07 Vpk, or 6.73 dB. The test signal 

level for a 50-W equivalent power should therefore be -13.7 dBV RMS total. 
 

One way to calculate the multitone distortion value is as the ratio of the RMS 

value of the test signal as compared to the RMS value of the sum of all of the many 

distortion products created. This is essentially the same as how THD is calculated. It is 

just the power ratio between the test signal and the distortion products. 
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In a simplified estimate, each combination of tones at frequencies f1 and f2 will 

create intermodulation distortion products at frequencies of m±n for all integer values of 

m and n, resulting in an exceedingly large number of products, especially when the 

number of unique combinations of two tone frequencies exist is large. Even with one 

tone per octave and 10 octaves, there are 11 tones and 55 combinations of two different 

tone frequencies. At 5 tones per octave and 51 tones, the number of combinations is 

1275. 
 

The simultaneous addition of the voltages of many sine waves means that the 

effective peak power level can be large. This invites the possibility that the input level to 

the QA40X may exceed the rated maximum of +32 dBV (40 Vrms, 56.5 Vpeak, 200 Wrms 

into 8 Ω). For this reason, it will often be desirable to include external attenuation in front 

of the QA40X input for amplifiers that could achieve peak voltages of 56.5 V at clipping. 

If external attenuation is in play, click on the dBV button and enter the amount of 

external attenuation into the external input gain box as a dB number, such as -20 dB. 
 

More tones per octave is not necessarily better for the same total RMS signal 

level. The close spectral spacing of a high number of tones per octave makes it difficult 

to distinguish IM frequency products from noise. A less-dense multitone choice, like 1 

tone per octave can make individual IM products more visible and distinguishable from 

noise. 
 

 Interpretation of the multitone measurement results is very subjective due to the 

very large number of distortion products produced, resulting in a dense group of very 

closely-spaced FFT lines, especially in the frequency range above 1 kHz, giving the 

appearance of "noise". How far down from the signal lines are the highest 

distinguishable distortion product lines is one useful result. 
 

 Begin by hitting File > New Settings to start with a clean slate. 

 Turn off the right channel. 

 Set the full-scale input to 42 dBV. 

 Set the sample rate to 192 kHz. 

 Set the FFT size to 256k, averages to 10 and window to Hann. 

 Hit the MULTITONE button in the Generator area.  

 Right click on it to bring up its dialog and select one tone per octave. 

 Select -13.7 dBV total RMS level for 50 Watts equivalent peak output swing. 

 Add the measurements RMS dBV, Pk dBV and RMS Pwr Watts. 

 Set Ymin to -140 dBV and decrement Ymax to +20 dBV. 

 Hit RUN. 
 

Go to File > Save Settings and save this setup file as "Multitone IM.settings". 

 

The large FFT of 256k and the 10 averages helps provide a clearer display of the 

complex result and a smaller amount of noise, but increases the amount of time for a 

complete result to appear after all of the averages are taken. Be patient. 
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Observe the multitone FFT display with 11 sinusoids each at +8.7 dBV (2.72 Vrms, 

3.85 Vpk, 42.3 Vpk total, 112 W; scope looks like 28 Vpk) and average power of 9.13 

Watts.  The top of the FFT noise floor between the tones includes the multitone IM 

products. This floor is rising with frequency, especially as 10 kHz is approached and 

exceeded. It has reached about -102 dBV at 20 kHz. This is partly due to reduced 

negative feedback loop gain at higher frequencies. Click on the Multitone button to turn 

the tones off. Notice that the FFT noise floor is now largely flat with frequency at about -

120 dBV at 20 kHz. 

 

 
 

Figure 19: Multitone IM, 50 Watts Equivalent 

 

Since  multitone distortion is seen here to be a function of frequency, it makes 

sense to quantify its value at a specified frequency, such as 20 kHz. Here the highest 

value of the products is about -102 dBV at 20 kHz and the 50-Watt peak-equivalent 

power level corresponds to a 26 dBV sine wave, so it seems reasonable to refer to the 

multitone distortion here as -128 dB at 20 kHz. 
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Crosstalk 
Crosstalk versus frequency is measured by looking at the frequency response of 

the undesired signal path from one channel of an amplifier to the opposite channel in a 

stereo amplifier. Here we illustrate measuring the frequency response of the crosstalk 

path from the left channel of the amplifier to the right channel of the amplifier.  
 

The QA40X sends a signal to the left channel amplifier (the aggressor) and 

receives the crosstalk signal from the output of the right channel amplifier (the victim). 

The right channel of the QA40X receives and measures the output of the right channel 

amplifier. The QA40X receives the signal from the left channel of the amplifier and uses it 

as the dBr signal reference against which the crosstalk signal from the left channel is 

measured.  
 

Crosstalk is measured by connecting the left amplifier's input to the QA40X left 

channel output, making the left channel amplifier the aggressor. The left amplifier is 

delivering 10 Watts (19.1 dBV) to its 8-Ω load. The right channel amplifier is the victim.  

Its input is shorted. Its output is the small crosstalk signal, which is delivered to the 

QA40X right channel input. A frequency response measurement is then run on this 

arrangement. Note that in some amplifiers measured crosstalk can change a bit with the 

power level at which the aggressor is set. Having no load on either the aggressor 

channel or the victim channel may also yield a different reading. Always load both 

amplifier outputs. 
 

 Short the right channel input of the amplifier. 

 Connect the right channel amplifier output to the right input of the QA40X. 

 Connect the left channel input of the amplifier to the left output of the QA40X. 

 Connect the left channel amplifier output to the left input of the QA40X. 

 Connect an 8-Ω load resistor to each amplifier output. 
 

 Hit File > New Settings to start with a clean slate. 

 Set the full-scale input to 42 dBV. 

 Increment the FFT size to 64k, increment averages to 4. 

 Set the sample rate to 96 kHz. 

 Increment Ymin to -100 dBV and leave Ymax at +20 dBV. 

 Click on Frequency Response in the Generator section.  

 The Sys: GenEx tile provides the Exponential Frequency Chirp stimulus. 

 Set it to -6.3 dBV to feed the left channel amplifier with 25.4 dB gain for 10 Watts. 

 Click RUN. 
 

Go to File > Save Settings and save this setup file as "Crosstalk.settings". 
 

A flat frequency response for the left aggressor channel will appear. A crosstalk 

frequency response with a lot of loss (hopefully) will appear in the plot for the right 

channel.  
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Hit the dBr button, right-click and choose the 1-kHz signal level to be at 0 dBr. 

Re-adjust Ymin to -100 dBr. 
 

This is the crosstalk level and frequency response. The BC-1 amplifier was not 

measured for crosstalk because the version used in the tests in this tutorial was 

configured as a monoblock. Instead, the Super Gain Clone LM3886 stereo amplifier I 

designed was measured for crosstalk [2]. Crosstalk is -70 dB at 1 kHz, rising to -60 dB at 

20 kHz.  

 

 

 
 

Figure 20: L2R Crosstalk of The Super Gain Clone Stereo Amplifier 

 

Output Impedance and Damping Factor 
Here the output impedance of the BC-1 amplifier will be measured as a function 

of frequency. A convenient way of measuring amplifier output impedance and damping 

factor (DF) as a function of frequency in the lab with a stereo amplifier is to back-drive 

the right-channel output with the left-channel output through a resistor, like 100 Ω. The 

input of the right channel amplifier is grounded. The frequency response of the resulting 

signal at the output of the right channel is then measured. 
 

The BC-1 amplifier used in these tests was configured as a monoblock, so a 

different test amplifier was used to drive the output of the BC-1 through the 100-Ω 

resistor. This approach is completely valid, and is independent of the voltage gain of the 
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driving test amplifier. A single-channel damping factor measurement is demonstrated in 

the automated measurements further below. 
 

Here the right-channel QA40X output drives the input of the test amplifier. The 

output of the test amplifier is connected to the output of the BC-1 through a 100-Ω 

resistor. The input of the BC-1 is grounded. The output of the BC-1 drives the QA40X 

right-channel input. The output of the test amplifier is connected to the left-channel 

input of the QA40X, so we see what goes into the back-drive resistor. 
 

The 100-Ω series back-drive resistor forms a voltage divider with the shunting 

output impedance of the BC-1, resulting in a large amount of attenuation when the 

frequency response of this path is measured. 
 

This arrangement is similar to that for measuring crosstalk, but here the 

"crosstalk" is from the back-drive arrangement. If we use a 100-Ω back-drive resistor, 

and the loss from the left-channel test amplifier output to the right-channel (BC-1) 

amplifier output is 60 dB, then the output impedance of the BC-1 is 0.1 Ω. Amplifier 

output impedance is measured and plotted as a frequency response in dBV at the right-

channel (BC-1) amplifier output.  
 

Damping factor is 8 Ω divided by the amplifier output impedance. If the 

measured output impedance is 0.1 Ω, then DF is 80. The DF need only be spot checked 

at a few frequencies (e.g., 20 Hz, 1 kHz, 20 kHz) rather than plotted. 
 

 Short the right-channel input of the amplifier (BC-1). 

 Connect the right amplifier (BC-1) output to the right input of the QA40X. 

 Use the quasi balanced/differential arrangement described on page 6. 

 Connect the left input of the (test) amplifier to the right output of the QA40X. 

 Connect an 8-Ω load to the left (test) amplifier output. 

 Connect the left (test) amplifier output to the left input of the QA40X. 

 Connect a 100-Ω 5-Watt resistor between the test and BC-1 amp outputs. 

You will measure the frequency response in the right channel of the QA40X.  
 

 Hit File > New Settings to start with a clean slate. 

 Set the full-scale input to 18 dBV. 

 Set the sample rate to 96 kHz. 

 Increment the FFT size to 64k and increment system averages to 4. 

 Set Ymin to -100 dBV and leave Ymax at +20 dBV. 

 Click on Frequency Response in the Generator section and set its level to -20 dBV.  

 The Sys: GenEx tile provides the Exponential Frequency Chirp stimulus. 
 

 Click RUN. 
 

Go to File > Save Settings and save this setup file as "Output Z.settings". 
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A frequency response plot with significant loss will appear in the right-channel 

FFT  display. This is the frequency response of the right channel (BC-1) amplifier's output 

impedance. A loss of 60 dB would correspond to output impedance of 100 Ω/1000 = 0.1 

Ω, which would result in a damping factor of 80. Hit the dBr button, right-click and 

choose the 1-kHz signal level to be at 0 dBr. Re-adjust Ymin to -100 dBr. 

 

 
 

Figure 21: BC-1 Output Impedance Frequency Response 
 

Add a cursor C1 to the right channel (red) by pushing the C1 button and clicking 

on the RIGHT button. You may have to drag the control area upward to see the cursor 

buttons. Drag the cursor left and right to see that the right channel is down by 71 dB at 

100 Hz, 71 dB at 1 kHz, 64 dB at 10 kHz and 58 dB at 20 kHz. The corresponding dB 

ratios are 3550, 3550, 1580 and 800. Output impedances are 0.028 Ω at 100 Hz, 0.028 Ω 

at 1 kHz, 0.063 Ω at 10 kHz and 0.125 Ω at 20 kHz. Damping factors are 286 at 100 Hz, 

286 at 1 kHz, 127 at 10 kHz and 64 at 20 kHz.  
 

While the DF is 286 at low frequencies, it falls to about 64 at 20 kHz. The DF of 

most power amplifiers decreases at higher frequencies because there is less negative 

feedback and/or as a result of the inductance of its output coil. A damping factor of 64 

at 20 kHz is quite good. The BC-1 has an output coil whose inductance is roughly 1.5 µH, 
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and whose impedance is 0.19 Ω at 20 kHz, actually a bit higher than measured by this 

test. Measurement of such low impedances at high frequencies like 20 kHz can vary by 

minor differences in the measuring arrangement. 

 

Automated Measurements 
The measurements made above were carried out manually. Using saved analyzer 

settings, those measurements were not too difficult. However, the QA40X software 

includes automated measurements that can make some of those measurements easier 

and faster. Automated measurements can also make possible measurements that could 

not usually be made manually, such as plotting THD vs. frequency for several different 

power levels, all on the same plot. The measurements illustrated below were made using 

automated measurements. 
 

The Automated tests include: 

 Power Output - THD vs Power at 1 kHz 

 THD vs Power at 10 kHz 

 THD versus Frequency 

 THD vs. Frequency vs. Output Power Level 

 Frequency Response 

 Frequency Response by Chirp 

 Output Impedance and Damping Factor 

 Crosstalk 

 Intermodulation Distortion 

 Intermodulation Distortion Alternative 
 

Each one of the automated tests below is written in a stand-alone format for all 

of the steps required. Many of those tests have the same or similar setup steps in 

common. In practice, an automated test has a group of setup steps to be done first using 

the control panel and the "add measurements" selections. Most of the setup here can be 

entered from a file that has been stored from previous tests via the File > Save Settings 

command. Those settings can then be entered via the File > Load Settings command. The 

THD Settings file can usually be loaded to avoid having to do many of the settings steps.  
 

Some of the measurement settings will have already been set to acceptable 

defaults. Some settings shown in the setups below are optional, such as an extra tile to 

display THD in percent. The actual value of some settings is also often non-critical to a 

given test, such as the sample rate or FFT size. A sample rate of 96 kHz and FFT size of 

64k will almost always work, but the higher frequency of 192 kHz will speed up the 

measurement, and a larger FFT will provide better accuracy at lower frequencies. Do not 

use averaging in any of the automated tests. 
 

After the measurement setup is completed, one of the automated tests is chosen 

for the measurement from the "automated tests" tab. At that point, a dialog box for that 

automated test will come up where the user sets values and parameters for the test. In 

some cases a default setting comes up in the dialog box that is perfectly fine. When the 
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user hits "OK" upon completion of the dialog entries, the automated test is run. The 

automated tests dialog box is how below in Figure 22. 

 

 

 
 

Figure 22: Screenshot showing the Automated Tests Dialog 

 

Alternatively, you can enter a setup file into the QA40X Settings File to Load box 

by browsing to the appropriate settings file and double clicking on it. When you select 

an automated test, all of its settings will be the same as those used in the previous run of 

that automated test. Importantly, this includes the QA40X Settings File to Load if that file 

was previously entered for that automated test. This means that in many cases you can 

just choose the automated test and hit OK and have it run. 
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At the completion of most automated settings runs, a small dialog box will come 

up with the radio-button options of Add to New Graph or Add to Existing Graph. Choose 

the former to just get the graph for the current run. 

 

After an automated run, you can make changes to the measurement settings or 

the automated test settings. Just click out of the plot that was created. That will get you 

back to the measurement settings view with the dashboard. Then you can hit F3 to bring 

back up the automated test dialog where you can make changes in its settings and then 

re-run the automated test.  

 

CAUTION! when you have clicked out of the plot and gotten back to the 

measurement settings and dashboard view, changes to the measurement settings you 

make will likely not be respected by the automated test to follow if the automated test 

had a measurement file entered into it. The automated test will work off of that 

measurement file and will not pay attention to changes you have made in the dashboard 

view.  

 

For example, let's say you did an automated run with no external attenuator. 

Then you insert a 6-dB external attenuator and change the dBV input gain value to -6 

dBV in the dashboard view after the automated run. This will not give the desired and 

expected same result. The next automated run will run based on the 0 dBV value that 

was previously used and which is still in the measurement file. When that next 

automated run starts, it will literally change the dBV input gain value back to what is in 

the measurement file. The same thing will happen if, for example, you change Ymin 

between automated runs. The new Ymin will not be used. 

 

However, if you delete the measurement file from the automated test (QA40X 

Settings File to Load Box), the automated test will not fetch a measurement file and will 

respect changes you make at the dashboard view between automated runs. Without a 

measurement file to fetch, it will use the setup that is in the current dashboard view. The 

orange annunciator in the upper left of the display will tell you what dBV input gain 

value is being used. 

 

Power Output - THD vs Power at 1 kHz 
Maximum power output was determined manually in the THD-1 vs. output power 

section above by watching THD increase as the power was increased by manually 

incrementing the Gen 1 signal level. Here we will use an automated test to plot THD-1 as 

a function of power level. This can be done for other selected frequencies as well. 
 

The automated THD vs power test executes a large number of measurement 

runs, each with an increased signal level driving the power amplifier while tracking THD. 

The test is run at a selected frequency and the increments in the driving signal amplitude 

are by a chosen amount of dB, such as by 0.5 dB (or less). A change of 0.5 dB is about 

12% in power - a bit much. The test is started at a selected dBV driving voltage and 
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ended at a selected dBV driving voltage. The test can be stopped at a selected value of 

THD percentage, such as 1%. Conveniently, the full-scale input attenuation is auto-

incremented as the amplifier output voltage increases.  
 

In normal use, this test will keep increasing the amplifier power level until 

clipping is reached or approached. For some amplifiers it is possible that the input level 

to the QA40X will exceed the rated maximum of +32 dBV (40 Vrms, 56.6 Vpeak and 200 

Wrms into 8 Ω). Moreover, it is recommended that some margin against the +32 dBV 

maximum analyzer input be allowed, like 1 dB or more). This means that the user should 

be mindful of this issue for amplifiers rated at 100 W or more. For this reason, it will 

often be desirable to include external attenuation in front of the QA40X input. If external 

attenuation is in play, right click on the dBV button and enter the amount of external 

attenuation into the external input gain box as a negative dB number, such as -20 dB. 
 

The burst nature of this test can be made to relax the necessary power rating of 

the load resistor by setting the analyzer to insert up to a 2-second pause between the 

repeated measurement runs. Go to Edit > Settings > Pause Acquisitions to do this. The 

reduced duty cycle of the measurement bursts will cause the load resistor to have less 

time to reach a high temperature during the repeated measurements. This will also 

reduce heating of the amplifier. 
 

If the gain of the amplifier is known, here 28.4 dB, appropriate start and finish 

input signal levels can be determined. If the desired starting power is 1 watt (2.83 Vrms 

or +9.0 dBV into 8 Ω), then the starting voltage can be set to -19.4 dBV. If the expected 

clipping point is 200 watts (40 Vrms or +32 dBV), then the ending input voltage can be 

set to +3.6 dBV.  
 

This measurement can take some time. Measuring from 1 W to 180 W (22.6 dB in 

power range) in 0.2-dB steps (about 5% in power) will require 113 runs. Choices of 

generous FFT sizes can make the time for the measurement quite long. For the BC-1 

amplifier here, the measurement range will be set to go from 1 W to clipping at about 

180 W. With 192 kHz sampling and a 32-k FFT, this test took over 3 minutes. 
 

Connect the left channel + output of the QA40X to the input of the amplifier. 

Unused analyzer inputs should be grounded with BNC terminators. Connect the amplifier 

to its 8-Ω load and to the QA40X left channel - input. 
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 42 dBV and set the sample rate to 192 kHz. 

 Increment FFT size to 64k, averages should be Off, choose the Hann window. 

 Add the measurements Sys: Gen 1, Pk Vrms, RMS dBV and RMS Power Watts. 

 Add the measurements THD %, THD+N %, THD dB, THD+N dB. 

 Right click on dBV; set input gain if an external attenuator is being used. 

 Set Ymin to -120 dBV and Ymax to +40 dBV. 
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Go to File > Save Settings and save this setup file as "THD-1 vs Pwr Auto.settings". 
 

 Go to Automated Tests > PWR: THD Versus Power. 
 

In the THD Versus Power dialog do the following: 

 Select units as dBV. 

 Uncheck the "Measure THD+N instead of THD" box. 

 Select start and stop levels as -19.3 dBV and +3.1 dBV. 

 Set the increment to 0.2 dB. 

 Set the frequency to 1 kHz. 

 Set the load impedance to 8 Ω. 

 Check the box "Autoset Input Range". 

 Set the input level range adder at 12 dB (see below). 

 Set distortion measurement stop to 20 kHz. 

 Check the box "Enable Early Abort". 

 Set abort minimum power level to 0.1 W. 

 Set abort maximum THD to -40 dB (1%). 

 Set the series name to "THD_1 vs Power" or the like. 
 

Hit OK - the THD vs power measurement runs will begin. 
 

Observe the Gen 1 voltage and power increase with each measurement run. The 

full scale input attenuator will increment as power is increased, causing a relay click. 

Watch the THD reading begin to increase as power approaches clipping. Watch the 

reported power when clipping occurs and THD-1 rises sharply, here about 170 Watts. 
 

A plot of THD-1 vs Power will appear after the run is completed. Add the title 

"THD-1 vs Power". The plot may be hidden behind the main window. Right click on the 

plot and select "save image as ...". and save it in the form you want (PNG, GIF, JPEG, TIFF 

or BMP) to the folder where you are storing plot results. You can revise the options and 

repeat the run by Xing out of the plot and hitting F3. 

 

Note that the input level range adder, whose default is 18 dB, is the amount of 

signal headroom for the measurement. It is the amount of headroom above the full-scale 

input (FSI) value for the expected input signal amplitude. It controls the input level at 

which the full-scale input attenuator is automatically set to greater attenuation as the 

input signal amplitude increases as the THD vs. power test progresses to higher power. If 

the input level range adder is set to 18 dB, and the input signal increases above 0 dBV, 

for example, the full-scale input setting will be automatically increased to the next higher 

amount of attenuation, in this case +24 dBV. In most cases, an input level range adder of 

12 dB is adequate. Higher FSI settings can increase measured noise in some cases 

because the analyzer is having to work with a smaller input signal amplitude. 
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Figure 23: THD vs. Power at 1 kHz 

 

The abort maximum THD setting will stop the test if the THD reaches the chosen 

level, like 1%. This prevents the amplifier from going into heavy clipping or overload if 

the input level is further automatically incremented beyond the point at which THD 

reaches the set percentage. For this abort to work, the amplifier power level must be 

greater than the power level specified by the abort minimum power level setting. The 

enable early abort box must be checked for this feature to act. 

 

If you want to re-run your last test, after, e.g., making a change to the automated 

test settings, press F3. This action will send you back to the automated menu to change 

the parameters for the next run.  
 

Now conduct the above test with the "Measure THD+N instead of THD" box 

checked. Note in the plotted result that THD+N rises at lower power levels because of 

noise in the amplifier. This test was run with a measurement bandwidth 20 kHz. Some 

analyzers will run this test with a bandwidth of 80 kHz, which will result in a bit more 

noise. At the end of the run, a plot of THD-1+N vs. power will appear. Add the title 

"THD-1+N vs Power". 
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Figure 24: THD+N vs. Power at 1 kHz 

 

THD vs Power at 16 kHz 
This test is the same as the one above, but conducted at 16 kHz to see the effects 

of distortion at higher fundamental frequencies. In this test, the QA40X will show FFT 

harmonics out to 80 kHz, well beyond 16 kHz, to capture many of the lower-order 

harmonics up to the 5th (choosing 16 kHz allows measurement of the important 5th 

harmonic within the maximum analyzer bandwidth of 80 kHz). 
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 42 dBV. 

 Set the sample rate to 192 kHz. 

 Increment FFT size to 32k and choose the Hann Window. 

 Add the measurements Sys: Gen 1, Pk Vrms, RMS dBV and RMS Power Watts. 

 Add the measurements THD %, THD+N %, THD dB, THD+N dB. 

 Right click on dBV; set input gain if an external attenuator is being used. 

 Set Ymin to -120 dBV and Ymax to +40 dBV. 

 In XLOG dialog, start frequency 1 kHz, stop frequency 80 kHz. 

 Hit the THD button. Right click, set start frequency to 1 kHz, stop 80 kHz. 
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Go to File > Save Settings and save this setup file as "THD_16 vs Pwr Auto.settings". 
 

Go to Automated Tests > PWR: THD Versus Power. 

In the THD Versus Power Dialog: 
 

 Select units as dBV. 

 Leave unchecked the Measure THD+N Instead of THD box. 

 Select start and stop levels as -19.3 dBV and +3.1 dBV. 

 Set the increment to 0.2 dB. 

 Set the frequency to 16 kHz. 

 Set the load impedance to 8 Ω. 

 Select autoset input range. 

 Set input level range adder to 18 dB. 

 Set distortion measurement stop to 80 kHz. 

 Select enable early abort. 

 Set abort minimum power level to 0.1 Watt 

 Set abort maximum THD to -40 dB (1%) 

 Set series name to "THD_16 vs Power" or the like 

Hit OK 

 

 

The THD vs power measurement runs will begin. Observe the Gen 1 voltage 

increase with each measurement run. Observe the full scale input to increment as power 

is increased. Observe the THD reading begin to increase as power approaches clipping. A 

plot of THD vs Power will appear. The choice of the 1 kHz starting measurement 

frequency eliminates unimportant measurements at low frequencies. You can revise the 

options and repeat the run by Xing out of the plot and hitting F3. Repeat the 

measurement with the "Measure THD+N instead of THD" box checked. 

 

Repeat the measurement with the "Measure THD+N instead of THD" box 

checked. 
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Figure 25: THD-16 vs. Power 
 

 

 

 
 

Figure 26: THD-16+N vs. Power 
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THD vs Power with 4-Ω Load 
This test measures THD-1 as a function of power with a 4-Ω load. An ideal 

amplifier would produce twice as much power into a 4-Ω load as into an 8-Ω load, but 

this will rarely be the case, mainly because the power supply will sag with the higher 

current demand. For measurements with a 4-Ω load (or other load not the 8-Ω default) 

the load impedance in the dBV settings must be set accordingly. For the automated test, 

the load impedance entry must be changed from the 8-Ω default to the 4-Ω value.  

 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 42 dBV and set the sample rate to 192 kHz. 

 Increment FFT size to 64k, averages should be Off, choose the Hann window. 

 Add the measurements Sys: Gen 1, Pk Vrms and RMS Power Watts. 

 Add the measurements THD %, THD+N %, THD dB, THD+N dB. 

 Right click on dBV; set Load Impedance to 4 Ω for correct power calculation. 

 Right click on dBV; set Input Gain if an external attenuator is being used. 

 Set Ymin to -120 dBV and Ymax to +40 dBV. 

 

Go to File > Save Settings, save setup file as "THD_1 vs Pwr 4 Ohms Auto.settings". 

 

 Go to Automated Tests > PWR: THD Versus Power. 

 

In the THD Versus Power dialog do the following: 

 Select units as dBV. 

 Leave unchecked the Measure THD+N Instead of THD box. 

 Select start and stop levels as -19.3 dBV and +2.7 dBV. 

 Set the increment to 0.5 dB. 

 Set the frequency to 1 kHz. 

 Set the load impedance to 4 Ω. 

 Check the box "Autoset Input Range". 

 Leave the input level range adder at 18 dB (see below). 

 Set distortion measurement stop to 20 kHz. 

 Check the box "Enable Early Abort". 

 Set abort minimum power level to 0.1 W. 

 Set abort maximum THD to -40 dB (1%). 

 Set the series name to "THD_1 vs Power" or the like. 

 

Hit OK - the THD vs power measurement runs will begin. THD begins to rise sharply at 

about 275 Watts into the 4-Ω load, indicating the early onset of clipping.  
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Figure 27: THD vs. Power at 1 kHz into 4-Ω Load 

 

THD vs Frequency vs Input level 
Here THD vs. frequency vs. input level will be measured by doing many runs in 

succession at different frequencies and input signal levels (actually input signal levels in 

dBV, not output power). The frequency range will be 20-20 kHz, the power range will 

increase in x-dB steps from about 1 W to about 140 W based on specified input dBV 

level range, where x is a step size that yields the number of power values to be plotted. 

Here 4 power levels are plotted at 1 W, 5.3 W, 27.3 W and 140 W. 
  

The start and stop dBV input levels and their increments (such as x = 6 dB) are 

then selected to set the power level curves to be plotted. The full scale input (FSI) range 

is automatically adjusted as the test power level is increased. 
 

If 3 points per octave are chosen over the 10 octaves from 20 Hz to 20 kHz, then 

each power level will require 30 runs. Each measurement will typically take about 2 

minutes with the settings below. If 3-dB increments in power from 1 watt to 128 W were 

chosen for a 21-dB range in power (e.g. 1 W to 128 W), then a total of 8 THD vs. 

frequency runs will be carried out. This totals 240 individual THD measurements, 

meaning that the total measurement can take a long time, here about 16 minutes with a 

high sample rate of 192 kHz and a 128k FFT; the latter is required for accurate results for 

reported distortion and output amplitude down to 20 Hz.  
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If the gain of the amplifier is known, here 28.4 dB, appropriate start and finish 

input signal levels can be determined. If the desired starting power is 1 watt (2.83 Vrms 

or +9.0 dBV into 8 Ω), then the starting voltage can be set to -19.4 dBV. If the desired 

maximum test level is the rated 140 W, then the ending input voltage can be set to +1.9 

dBV. This measurement can take some time. Measuring from 1 W to 64 W in 6-dB steps 

will require 4 runs, but will not get you to 140 W. The tricky part comes because 

amplitude values are quantized to the chosen amplitude step size. If you want to start at 

1 W and go to 140 W, you must pick a step size that yields the number of different 

amplitudes to be plotted and gets you just below +2.0 dBV 
 

Measurement bandwidth will be 80 kHz so as to capture as many harmonics as 

possible. Measurement bandwidth is set to start at 10 Hz to give margin against the first 

measurement at 20 Hz. The measurement takes a long time, so the sample rate is set to 

max of 192 kHz and the FFT is set to 128k with no averages. 
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 18 dBV and set the sample rate to 192 kHz. 

 Increment the FFT size to 128k and select the Hann window. 

 Increment Ymin to -120 dBV and Ymax to +40 dBV. 

 Add measurements Sys: Gen 1, THD %, THD+N % and RMS Power Watts. 

 Set Gen1 amplitude to -19.4 dBV. 

 In the XLOG dialog, set start frequency to 10 Hz, stop frequency to 80 kHz 

 Hit the THD button, right click and set start frequency 10 Hz stop 80 kHz. 

 For Fundamental Selection select Use Channel Peak in the THD dialog. 

 Use a 6-dB external attenuator and set dBV input gain to -6 dB. 
 

Go to File > Save Settings and save setup file as "THD vs Freq Auto.settings". 
 

    Go to Automated Tests > AMP THD Versus Frequency. 

 Leave unchecked the "Measure THD+N Instead of THD" box. 

 Select units as dBV and select start and stop levels as -19.4 dBV and +2.0 dBV. 

 Set the increment to 7.1 dB. 

 Set the start and end frequencies to 20 Hz and 21 kHz 

 Ignore the Hz per Step value. (It doesn't matter when using Log Step.)  

 Check the Log Step box and select 3 points per octave. 

 Check the Autoset Input Range box. 

 Set the Input Level Range Adder to 12 dB. 

 Hit OK 
 

The result is shown in Figure 28, after about 4 minutes. Power levels are 1 W 

(blue), 4 W (green), 23 W (orange) and 139 W (yellow). 
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Figure 28: THD vs. Frequency for Various dBV Input Levels 
 

Now do the same measurement, but with the "Measure THD+N Instead of THD" 

box checked. The THD+N results are shown in Figure 29.  
 

 
 

Figure 29: THD+N vs. Frequency for Various dBV Input Levels 
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Frequency Response 
This test will measure the frequency response of the amplifier at a fixed small 

level of 1 Watt. The measurement parameters will include input signal amplitude in dBV, 

load impedance, measurement frequency range. One Watt into 8 Ω corresponds to 2.83 

Vrms which corresponds to +9 dBV. If amplifier gain is 28.4 dB, an input level of -19.4 

dBV will deliver 1 W. The measurement is carried out with FFTs at a large number of 

discrete fundamental frequencies to determine the output amplitude at each frequency. 

The baseline measurement will first cover 20 Hz to 20 kHz, then measurements as low as 

2 Hz and high as 80 kHz will be done.  
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 18 dBV. 

 Set the sample rate to 192 kHz. 

 Increment FFT size to 128k, leave averages at Off, choose the flat top window. 

 Hit the Frequency Response button 

 Set Ymin to -100 dBV and Ymax to +20 dBV. 
 

Go to File > Save Settings and save this file as "Freq Response Auto.settings". 
 

Go to Automated Tests > AMP Frequency Response. 

 Set start and stop amplitudes to -19.4 dBV for output of about 1 W. 

 Ignore the Increment dB setting. 

 Set the frequency range to start at 20 Hz, end at 20 kHz (default). 

 Ignore the Hz per Step value. (It doesn't matter when using Log Step.)  

 Check the Log Step box and set points per octave to 3. 

 Check the Plot as Gain box and enter the series name. 

 Hit OK. 
 

The choice of log step means that the physical distance between the steps across 

the log scale of the X axis will be constant. If the log step option is not used, the 

measurement will take an extremely long time, stepping by a fixed frequency increment 

at a time all the way to 20 kHz. That increment would need to be small for adequate 

resolution at low frequencies. 
 

The plot screen is shown as the measurement is in progress, with the FFT line of 

the fundamental marching from left to right. When the sweep is completed, a plot of 

amplifier gain vs. frequency will appear, showing a flat response that falls by about 0.1 

dB at 20 Hz and 0.04 dB at 20 kHz.  
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Figure 30: Frequency Response 20 Hz to 20 kHz 
 

The use of the high sample rate makes the measurement go more quickly and 

keeps open the possibility of measuring the frequency response to 80 kHz. The FFT size 

is set to a generous value of 128k because a smaller FFT will result in serious 

measurement anomalies (errors) at the lowest frequencies. 
 

Now the frequency response over a wide bandwidth of 2 Hz to 80 kHz will be 

measured. The FFT will need to be much larger to provide satisfactory results down to 2 

Hz. X out of the plot and make the following changes to the setup and the Frequency 

Response measurement settings: 
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 18 dBV. 

 Set the sample rate to 192 kHz. 

 Increment FFT size to 512k, leave averages at Off, choose the flat top window. 

 Hit the Frequency Response button 

 Set Ymin to -100 dBV and Ymax to +20 dBV. 

 Increment the FFT size to 512k 

 Right click XLOG dialog, start frequency 2 Hz, stop frequency 80 kHz. 

 Right click RMS and set measurement start at 2 Hz and stop at 80 kHz. 
 

Go to File > Save Settings, save file as "Freq Resp Wide Auto.settings". 
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 Go to Automated Tests > AMP Frequency Response. 

 Set start and stop amplitudes to -19.4 dBV for output of about 1 W. 

 Ignore the Increment dB setting. 

 Set frequency range to start at 2 Hz, end at 80 kHz. 

 Ignore the Hz per Step value.  

 Check the Log Step box and set points per octave to 3. 

 Check the Plot as Gain box and enter the series name. 

 Hit OK. 
 

Response is down 0.4 dB at 10 Hz, 0.2 dB at 20 Hz, 0.1 dB at 20 kHz, 0.4 dB at 50 

kHz and 1.5 dB at 80 kHz. 
 

This measurement requires a much larger FFT to avoid low-frequency anomalies. 

The measurement will thus take much, much longer. It is a long way from 1 Hz to 80 kHz, 

especially when one must use 512-k FFTs to avoid anomalies at the very low starting 

frequencies. The plot took several minutes to complete. 
 

 
 

Figure 31: Frequency Response 2 Hz to 80 kHz 

 

Frequency Response by Chirp 
This is an alternative way of measuring amplifier frequency response, using a 

chirp stimulus signal. This approach takes less time than the frequency response 

measurement described above. The baseline measurement will first cover 20 Hz to 20 

kHz, then measurements as low as 3 Hz and high as 80 kHz will be made. 
 

 Hit File > New Settings. 

 Turn off the right channel. 
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 Set the full-scale input to 18 dBV. 

 Set the sample rate to 192 kHz. 

 Increment FFT size to 256k and set the FFT window to flat top (default). 

 Press the Frequency Response button. Right click to see Expo Chirp Options. 

 Note End Frequency is fixed at 96 kHz and Octaves is fixed at 12. 

 They set the span over which the frequency measurement extends. 

 Set Ymin to -120 dBV and Ymax to 20 dBV. 
 

Go to File > Save Settings and save as "Freq Resp Chirp Auto.settings". 
 

Go to Automated Tests > AMP Frequency Response Chirp. 

 Set analyzer output level to -19.4 dBV for about 1 Watt output. 

 Set octaves smoothing to 3. 

 Do not check Right Channel as Reference or Plot Right Channel or Plot Phase. 

 Check Plot as Gain. 

 Enter 1000 (Hz) where it says Normalize Frequency to 0 dB. 

 Enter series name. 

 Hit OK. 
 

The choice for Normalize Frequency to 0 dB sets the frequency at which the 

plotted response is normalized to read 0 dB for the frequency response. This will usually 

be set to 1000 Hz. 
 

A plot of frequency response will appear in Figure 31.  

 
 

Figure 32: Frequency Response by Chirp 
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The program does some auto-scaling of the Y axis. If none or some of the plot 

line is missing, the line is probably above the top 0-dB X axis on the plot. Set Ymin to -3 

dB. Set Xmin to 10 Hz and Xmax to 80 kHz. Frequency response is shown as down 0.35 

dB at 10 Hz, 0.1 dB at 20 Hz, 0.1 dB at 20 kHz, -0.6 dB at 50 kHz and 1.4 dB at 80 kHz.  

 

Output Impedance and Damping Factor 
The damping factor (DF) of a power amplifier is inversely related to its output 

impedance (Zout). It is technically defined as the ratio of the load impedance to the 

amplifier output impedance. In practice, on specification sheets it is always specified as 

the ratio of 8 Ω to the amplifier output impedance. Here the output impedance of the 

amplifier will be determined by measuring amplifier gain with and without an 8-Ω load. 

With the impedance data, the software will calculate and plot DF. It is crucial that the 

load resistor be non-inductive and no more than 2 feet from the amplifier output 

terminals for this impedance measurement technique to be reasonably accurate for 

frequencies above 1 kHz. Stray inductance of as little as 1 µH will adversely affect the 

reported DF. 
 

Zout and DF will be measured as a function of frequency from 20 Hz to 20 kHz. 

The measurement will be done at an output voltage level of 2.83 Vrms (+9 dBV), 

corresponding to 1 W into 8 Ω. If amplifier gain is 28.4 dB, as it is here, an input level of 

about -19.4 dBV will be applied to the amplifier. Choosing FSI of 18 dBV (i.e., below 24 

dBV) optimizes QA403 sensitivity for potentially more accurate results. The measurement 

is done in two phases, the first with an 8-Ω load and the second with a specified 1-MΩ 

load (open circuit). 
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 18 dBV. 

 Set the sample rate to 192 kHz. 

 Increment FFT size to 128k, averages should be Off, and choose Hann window. 

 Add the measurements Sys: Gen 1, RMS dBV, RMS Volts and RMS Power Watts. 

 Hit GEN 1 and set the GEN1 level to -19.4 dBV if amplifier gain is 28.4 dB. 

 Set the RMS measurement stop frequency to 21 kHz. 

 Set dBV load impedance to 8 Ω.  

 Set Ymin to -120 dBV and Ymax to 20 dBV. 
 

Go to File > Save Settings and save file as "Output Z Auto.settings". 
 

Go to Automated Tests > PWR Output Impedance. 

 Set QA40X output power level to -19.4 dBV (not critical). 

 Set start & stop frequencies to 20 Hz-20 kHz. 

 Ignore the Hz per Step value. (It doesn't matter when using Log Step.)  

 Check the Log Step box and choose 3 points per octave. 

 Enter load impedance of 8 Ω for the first pass. 

 Enter load impedance of 1000000 (1 Meg) for the second pass. 
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 Check the box Plot Damping Factor. 

 Hit OK. 
 

The choice of a 192 kHz sample rate makes the measurement go more quickly. 

The choice of a 128 kHz FFT helps preserve accuracy down to 20 Hz. 

The choice of measurement frequency stop of 21 kHz gives margin against band edge. 
 

The program will ask you to connect an 8-Ω load, then hit OK. 

You will see an FFT line march across the screen, at about 1 Watt. 

When complete, it will ask you to set the load impedance to 1000000 ohms (infinity). 

Disconnect the 8-Ω load and hit OK. 

You will see an FFT line march across the screen. 
 

A plot of the output impedance vs frequency will appear. Enter the title of the 

graph as Zout and Damping Factor. The plot spans Zout and DF ranges that are auto-

scaled by the QA40X.  
 

For the BC-1, the reported output impedance at low frequencies is 0.028 Ω 

(DF=286), rising to 0.038 Ω (DF=211) at 10 kHz and rising further to 0.066 Ω (DF=121) at 

20 kHz, as seen in Figure 33. The rise at higher frequencies is mainly due to the output 

inductor in the BC-1 (not necessarily due to the falling amount of negative feedback). A 

DF of 121 is remarkably high at 20 kHz. 
 

 
 

Figure 33: Output Impedance and DF vs. Frequency 
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If you set the stop frequency to 80 kHz, after changing the setup XLOG and RMS 

measurement stop frequencies to 80 kHz, the Zout will be plotted up to 80 kHz. Here the 

output impedance rises to 0.036 Ω at 80 kHz, corresponding to a DF=20. 
 

 
 

Figure 34: Output Impedance and DF vs. Frequency to 80 kHz 

 

Crosstalk vs Frequency 
Here an automated test will be used to measure the crosstalk vs. frequency for a 

stereo amplifier. Crosstalk versus frequency is measured by looking at the frequency 

response of the undesired signal path from one channel of an amplifier to the opposite 

channel. Here we illustrate measuring the frequency response of the crosstalk path from 

the right channel of the amplifier to the left channel of the amplifier (R2L) and from the 

left channel to the right channel L2R).  
 

One channel will be the "aggressor", amplifying the test signal and delivering 

about 10 W to an 8-Ω load. The other channel will be the "victim", whose output will be 

measured as the frequency response of the crosstalk. One channel of the QA40X will be 

used to measure the frequency response of the crosstalk path from the output of the 

aggressor channel to the output of the victim channel. The automated test measures 

both directions of the crosstalk path in two runs. 

 

The frequency response is measured by stepping the frequency through the 

frequency range at a chosen number of steps per octave at a fixed amplitude, while 

measuring the output of the aggressor channel and the victim channel. The dB difference 

in the received signal levels is reported as the crosstalk value. In the first run, the right 
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channel is the victim, with the right output of the QA40X muted so that the right channel 

of the amplifier gets no input. The roles are reversed in a second run so that crosstalk in 

both directions (L2R and R2L) is measured and plotted. 
 

The QA40X right output sends a signal to the left channel amplifier (the 

aggressor) and receives the crosstalk signal from the output of the right channel 

amplifier (the victim) into its right input.. The left channel of the QA40X receives and 

measures the output of the left channel amplifier. The right input of the QA40X receives 

the signal from the right channel of the amplifier and uses it as the dBr signal reference 

against which the crosstalk signal from the left channel is measured. A frequency 

response measurement is then run on this arrangement. 
 

The BC-1 amplifier was not measured for crosstalk here because the version used 

in the tests in this tutorial was configured as a monoblock. Instead, the Super Gain Clone 

LM3886 stereo amplifier I designed was measured for crosstalk [2]. Crosstalk was -64 dB 

at 1 kHz, rising to -51 dB at 20 kHz. 

 

Crosstalk in both directions (L2R and R2L) will be measured. Both amplifier 

outputs should be loaded by an 8-Ω load resistor. Crosstalk will be measured at only one 

power level, which should be about 10 Watts, but is not critical. 

 

Connect the left output of the QA40X to the left input of the amplifier. 

Connect the left output of the amplifier to the right input of the QA403. 

Connect the right output of the QA403 to the right input of the amplifier. 

Connect the right output of the amplifier to the left input of the QA403. 
 

 

 Hit File > New Settings. 

 Set the full-scale input to 42 dBV. 

 Set the sample rate to 192 kHz, FFT size to 128k and averages Off. 

 Set Ymin to -120 dBV and Ymax to +20 dBV 
 

 

Go to File > Save Settings and save this setup file as "Crosstalk Auto.settings". 
 

Go to Automated Tests > AMP Crosstalk. 
  

 Set QA40X aggressor output start level to -6.3 dBV, stop level to -6.3 dBV. 

 Only one signal level will be measured, here 10 Watts. 

 Ignore the dBV increment. 

 Set start and stop frequencies to 25 Hz and 20000 Hz. 

 

 Ignore the Set Hz per Step value. (It doesn't matter when using Log Step.)  

 Check the Log Step box and select 1 point per octave. ?? 

 (this avoids the influence of 60-Hz hum.) 

 Check Autoset Input Range box and leave Range Adder at the 18-dB default. 
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 Check Measure Right to Left Crosstalk (left channel is the victim). 

 Check Measure Left to Right Crosstalk (right channel is the victim). 

 Enter a Series Name. 

 Start the run by hitting OK. 
 

 As the test progresses, the aggressor signal is at about +6 dBV and its frequency 

increases as its FFT line moves to the right. The orange annunciator in the upper left will 

indicate which QA40X output is muted for each of the two runs. At the conclusion of the 

measurement runs, a plot showing crosstalk will appear. Give the plot a title. Set Xmin to 

20 (Hz) and Xmax to 20,000 (Hz). Crosstalk for the Super Gain Clone amplifier is about -

69 dB at low frequencies, rising to about -64 dB at 1 kHz, and rising further to -51 dB at 

20 kHz. 
 

 
 

Figure 35: Crosstalk of Super Gain Clone Stereo Amplifier 

 

Intermodulation Distortion vs dBV Input 
Both CCIF 19+20 kHz (ITU) and SMPTE (60 Hz and 4 kHz, 4:1) intermodulation 

distortion will be measured as a function of dBV input amplitude in this test. 
 

 Hit File > New Settings. 

 Turn off the right channel. 

 Set the full-scale input to 42 dBV. 

 Set the sample rate to 192 kHz and increment the FFT size to 128k. 

 Set Ymin to -120 dBV and Ymax to +40 dBV. 

 Add Pk dBV, Pk Vrms, Peak Pwr Watts and RMS Pwr Watts measurements. 
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Go to File > Save Settings and save file as "CCIF IMD vs dBV Auto.settings". 
 

Go to Automated Tests > AMP IMD. 

 Check ITU. 

 Set start and stop levels to -20 dBV and +1 dBV, respectively. 

 Select dB increment as 0.2 dB. 

 Set IM order to 5. 

 Hit OK. 
 

 
 

Figure 36: CCIF 19+20 kHz IM Distortion vs dBV Input to Amp 
 

With 0.2 dB amplitude increments, this measurement will take about 3.5 minutes. 

A larger increment will take less time, but granularity of results as a function of input 

amplitude will suffer. A plot showing CCIF 19+20 kHz (ITU) will appear. The amplifier 

clips at just over 0.0 dBV output from the analyzer. IMD is below -120 dBc all the way up 

to clipping. 
 

Hit F3 to go back and change the AMP IMD automated test settings. 

 Check SMPTE. 

 Set start and stop levels to -20 dBV and +2 dBV, respectively. 

 Select dB increment as 0.2 dB. 

 Set IM order to 5. 

 Hit OK. 
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With 0.2 dB amplitude increments, this measurement will take about 5 minutes. A 

plot showing SMPTE (60 Hz and 4 kHz, 4:1) intermodulation distortion will appear. 
 

 
 

Figure 37: SMPTE IM Distortion vs dBV Input to Amp 

 

Intermodulation Distortion vs Power 
Both CCIF 19+20 kHz (ITU) and SMPTE intermodulation (60 Hz and 4 kHz, 4:1) 

distortion will be measured as a function of amplifier output power in this test. Load 

impedance will thus have to be entered for this test.  
 

CCIF IMD will now be discussed and measured. At rated sine wave average (aka 

RMS) power of 140 W, peak output voltage is 47.3 Vpk. With two equal tones in the CCIF 

test, this corresponds to two tones, each of 23.7 Vpk, further corresponding to 16.7 

Vrms, still further corresponding to 35 W per tone, for total two-tone RMS power of 70 

W (conveniently half the rated sine wave power of 140 W). At 16.7 Vrms, each tone will 

be at 24.5 dBV. Thus, when each tone is at 24.5 dBV, the amplifier is operating at its 

equivalent full power rating of 140 W. This is the per-tone amplitude at which CCIF 

distortion should be measured at full "rated" power. With amplifier gain of 28.4 dB, this 

corresponds to per-tone input voltage of -3.9 dBV. If the measurement is stopped at a 

dashboard reading of 70 Wrms, then the resulting FFT will depict performance at rated 

amplifier power. 
 

 Hit File > New Settings. 

 Turn off the right channel and set the full-scale input to 42 dBV. 

 Set the sample rate to 192 kHz, increment FFT size to 64k, set window to Hann. 
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 Add measurements Sys: Gen1, Sys: Gen2, RMS Power Watts and Pk dBV. 

 Set Gen1 and Gen2 to -3.9 dBV 

 Set XLOG and RMS measurements to start 500 Hz and stop 50 kHz. 

 Set Ymin to -120 dBV and Ymax to +40 dBV 
 

Go to File > Save Settings and save setup file as "CCIF IMD vs Pwr Auto.settings". 
 

Hit RUN. 
 

The CCIF distortion products at 140 W equivalent power are shown below. they 

lie at (m ± n) Hz where M=19 kHz and n=20 kHz. Primary even-order products lie at 1 

kHz, 2 kHz, etc. Prominent odd-order products surround the 19 and 20 kHz pair of tones. 

Higher-order products can be seen surrounding the second harmonics of the tones in 

the vicinity of 38 kHz. 
 

 
 

Figure 38: CCIF 19+20 kHz IM Distortion at 140 W Equivalent Power 
 

The highest in-band products measured here lie at 1 kHz and 18 kHz and are 110 

dB down from the amplitudes of each tone. However, with respect to the 30.5 dBV 

amplitude of a 140-W sine wave, these products are down by 115 dB. 
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Go to Automated Tests > PWR IMD (ITU and SMPTE). 

 Check ITU. 

 Set start and stop levels to -20 dBV and 1 dBV, respectively. 

 Select dB increment as 0.2 dB and set IM order to 5. 

 Set Load Impedance to 8 Ω (or 4 Ω) (for proper power calculation) 

 Check Autoset Input Range. 

 Set input level range adder to 18 dB. 

 Hit OK. 
 

 
 

Figure 39: CCIF 19+20 kHz IM Distortion vs Amp Power Output 
 

With 0.2 dB amplitude increments, this measurement will take about 2 minutes. A 

larger increment will take less time, but granularity of results as a function of power will 

suffer. A plot showing CCIF 19+20 kHz (ITU) will appear. Note that power indicated on 

the X axis is the RMS power of the 2 tones combined, not the same as the single-tone 

sine wave average power. 
 

SMPTE IMD will now be discussed and measured. At rated sine wave average (aka 

RMS) power of 140 W, peak output voltage is 47.3 Vpk. With 60 Hz and 7000-Hz tones in 

a 4:1 ratio, the 60-Hz tone will be at 80% of the peak voltage, or 37.8 Vpk, and the 7-kHz 

tone will be at 20% of the peak voltage, or 9.46 Vpk. This corresponds to 26.7 Vrms and 

6.69 Vrms, respectively. This further corresponds to 89.1 W and 11.2 W, respectively, for a 

total average power of 100.3 W. At 26.7 Vrms and 6.69 Vrms, the tones are at 28.5 dBV 

and 16.5 dBV. Thus, when the tones are at these amplitudes, the amplifier is operating at 

its equivalent full power rating of 140 W. These are the per-tone amplitudes at which 

SMPTE distortion should be measured at full "rated" power. With amplifier gain of 28.4 

dB, this corresponds to tone input amplitudes of +0.1 dBV and -11.9 dBV. If the 
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measurement is stopped at a dashboard reading of 100.3 Wrms, then the resulting FFT 

will depict performance at rated amplifier power. 
 

 Hit File > New Settings. 

 Turn off the right channel and set the full-scale input to 42 dBV. 

 Set the sample rate to 192 kHz, increment FFT size to 64k, set window to Hann. 

 Add measurements Sys: Gen 1, Sys: Gen 2, RMS Power Watts and Pk dBV. 

 Set Gen1 to 60 Hz with amplitude +0.1 dBV. 

 Set Gen2 to 7000 Hz with amplitude -11.9 dBV. 

 Set XLOG and RMS measurements to start at 20 Hz and stop at 20 kHz. 

 Set Ymin to -120 dBV and Ymax to +40 dBV. 
 

Go to File > Save Settings and save setup file as "SMPTE IMD vs Pwr Auto.settings". 
 

 Hit RUN. 
 

 An FFT will appear that shows SMPTE distortion products when the amplifier is 

driven to 140 equivalent Watts. Distortion products are seen at 7 kHz ± n*60 Hz and at 

14 kHz ± n*60 Hz. 

 

 
 

Figure 40: SMPTE kHz IM Distortion at 140 W Equivalent Power 
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Go to Automated Tests > PWR IMD (ITU and SMPTE). 

 Check SMPTE. 

 Set start and stop levels to -20 dBV and +1.7 dBV, respectively. 

 Select dB increment as 0.2 dB. 

 Set IM order to 5. 

 Set Load Impedance to 8 Ω (or 4 Ω) (for proper power calculation) 

 Check Autoset Input Range. 

 Set input level range adder to 18 dB. 

 Hit OK. 
  

A plot showing SMPTE (60 Hz and 7 kHz, 4:1) intermodulation distortion as a 

function of power will appear. Note that power indicated on the X axis is the RMS power 

of the 2 tones combined, not the same as the single-tone sine wave average power. 
 

 
 

Figure 41: SMPTE IM Distortion vs Power 
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